Bug 238850 - logrotate script points to wrong log location
Summary: logrotate script points to wrong log location
Status: CLOSED DUPLICATE of bug 233760
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-03 13:06 UTC by Derek Atkins
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 14:49:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Atkins 2007-05-03 13:06:55 UTC
Description of problem:

The settroubleshoot logrotate configuration is broken.  I see this in my daily
emails:

/etc/cron.daily/logrotate:

error: error accessing /usr/local/var/log/setroubleshoot: No such file or direct
ory
error: setroubleshoot:1 glob failed for /usr/local/var/log/setroubleshoot/*.log
error: found error in /usr/local/var/log/setroubleshoot/*.log , skipping


Version-Release number of selected component (if applicable):

setroubleshoot-server-1.9.4-1.fc7

How reproducible:

Every night this happens.

Steps to Reproduce:
1. Install settroubleshoot-server
2. Wait for cron.daily to run at 4am
3. Look in root's email
  
Actual results:

See the email above.

Expected results:

It should rotate the proper log

Additional info:

/etc/logrotate.d/settroubleshoot contains a broken pointer:

[root@pgpdev ~]# more /etc/logrotate.d/setroubleshoot 
/usr/local/var/log/setroubleshoot/*.log {
...

This should probably be /var/log/settroubleshoot/*.log and not
/usr/local/var/log/...

Comment 1 Derek Atkins 2007-05-03 13:10:56 UTC
oops, this should be against devel, not test3.  Sorry.  This is against F7t4.

Comment 2 John Dennis 2007-05-03 14:49:21 UTC

*** This bug has been marked as a duplicate of 233760 ***


Note You need to log in before you can comment on or make changes to this bug.