Bug 238851 - missing Requires(post) and Requires(postun)
missing Requires(post) and Requires(postun)
Status: CLOSED DUPLICATE of bug 238917
Product: Fedora
Classification: Fedora
Component: fonts-hebrew-fancy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Kenigsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 09:09 EDT by Karsten Hopp
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-14 08:19:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2007-05-03 09:09:12 EDT
Description of problem:
fonts-hebrew-fancy has post/postun scripts which run fc-cache
You need to add the following to you spec file:
Requires(post): fontutils
Requires(postun): fontutils

Otherwise the ordering during an install isn't correct and you'll get an error:
  Installing: fonts-hebrew-fancy           ##################### [208/640]
/var/tmp/rpm-tmp.65093: line 1: fc-cache: command not found
error: %post(fonts-hebrew-fancy-0.20051122-1.fc6.noarch) scriptlet failed, exit
status 127


Version-Release number of selected component (if applicable):
fonts-hebrew-fancy-0.20051122-1.fc6
Comment 1 Dan Kenigsberg 2007-05-13 10:31:12 EDT
I suppose this may be consider a duplicate of bug 238917, and solved as detailed
in comment 1 therein. Am I right?
Comment 2 Karsten Hopp 2007-05-14 08:19:05 EDT
yes, you're right

*** This bug has been marked as a duplicate of 238917 ***

Note You need to log in before you can comment on or make changes to this bug.