Bug 238862 - cpio Illegal seek
Summary: cpio Illegal seek
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cpio   
(Show other bugs)
Version: 4.5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-03 14:18 UTC by Brian Smith
Modified: 2012-08-23 12:44 UTC (History)
3 users (show)

Fixed In Version: RHBA-2008-0719
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 19:57:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace output (97.85 KB, text/plain)
2008-06-13 10:08 UTC, Michal Nowak
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0719 normal SHIPPED_LIVE cpio bug fix update 2008-07-23 16:08:42 UTC

Description Brian Smith 2007-05-03 14:18:26 UTC
When using cpio-2.5-13.RHEL4 and attempting the command:

find . -print | cpio -oacB  --rsh-command=/usr/bin/rsh -O host:/backups/a.cpio

It returns:
host: Connection refused
cpio: host:/backups/a.cpio: Illegal seek

If I force install cpio-2.5-9.RHEL4.i386.rpm and use that binary, the command 
works.

Comment 1 Brian Smith 2007-05-03 14:37:36 UTC
I guess since I have a work around this can be medium

Comment 2 Radek Brich 2007-07-25 14:26:35 UTC
Well, I got different results:

# rpm -q cpio
cpio-2.5-13.RHEL4.i386
# find . -print | cpio -oacB  --rsh-command=/usr/bin/rsh -O host:/root/a.cpio
Segmentation fault
# find . -print | /tmp/cpio -oacB  --rsh-command=/usr/bin/rsh -O host:/root/a.cpio
20 blocks

The second binary is from 2.5-9.RHEL4. No doubt something is broken there...

Comment 3 RHEL Product and Program Management 2007-11-29 04:20:40 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Brian Smith 2007-11-29 15:15:50 UTC
FYI, this seems fixed in RHEL5

Comment 10 Michal Nowak 2008-06-13 10:08:45 UTC
Created attachment 309188 [details]
Strace output

Comment 22 errata-xmlrpc 2008-07-24 19:57:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0719.html


Note You need to log in before you can comment on or make changes to this bug.