Bug 238872 - Cannot type into xemacs and other text entry boxes
Cannot type into xemacs and other text entry boxes
Status: CLOSED DUPLICATE of bug 160544
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 11:50 EDT by Nick Fitzkee
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 16:12:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Fitzkee 2007-05-03 11:50:18 EDT
Description of problem:
Occasionally when using X programs, there are text entry boxes that cannot be
typed in to.  This occurs in MatLab as well as PyMOL, two non-Redhat binary
distributions based on glibc 2.4.  I had thought that an incompatibility in the
binary format was at fault, but now I have identified a text box in xemacs that
exhibits similar behavior.

Version-Release number of selected component (if applicable):
xemacs-common-21.5.27-8.fc6
xemacs-21.5.27-8.fc6
xorg-x11-drv-keyboard-1.1.0-2.1


How reproducible: 
Always on these systems 

Steps to Reproduce:
1.  Open xemacs
2.  Select Edit -> Find...
3.  Attempt to type into the "Search for" field
  
Actual results:

On my system, no matter what I type, the field remains empty, even when the
mouse is over that particular field.  The behavior is similar for MatLab when a
popup window is visible and also for the upper PyMOL window.  Generally, it
seems that certain applications, when two text entries are open, one cannot take
text input.

Expected results:

One should be able to type into all windows as long as mouse is over them and/or
they are focused.

Additional info:

These systems are: four identically configured dell Precision Workstation 340, a
Dell Precision Workstation 380, and a Dell Dimension 8200, all with 1.5 GB+ of Ram.

nVidia drivers are installed (1.0-9631)

freeGLUT is not installed, and instead I am using the standard SGI GLUT 3.7 (it
works better with dialbox drivers, etc.)
Comment 1 Jens Petersen 2007-05-03 20:21:12 EDT
It works for me in FC6 and current pre-release F7.

However if I click on the main XEmacs window again and then return
to the search dialog I can no longer input test there.

Sounds like your issue (in other apps too) is probably an X toolkit bug.
Comment 2 Ville Skyttä 2007-06-14 16:12:23 EDT
See also bug 160544, this sounds like a duplicate to me.

For me in KDE, returning back to the find dialog and resizing it downwards shows
that the input actually does get there, but goes in the bottom, below the dialog
borders into an area which wasn't visible before resizing.

*** This bug has been marked as a duplicate of 160544 ***

Note You need to log in before you can comment on or make changes to this bug.