Bug 238873 - brp-compress problem with man pages
brp-compress problem with man pages
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-rpm-config (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 11:51 EDT by Brenton Leanhardt
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 09:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2007-05-03 11:51:11 EDT
Description of problem:
I was packaging a mouse driver and I kept getting the following error:
File not found: /var/tmp/mouseemu-0.16-1-buildroot/usr/share/man/man8/mouseemu.8
 
It seems so how related to brp-compress being run.  If I comment that line out
in /usr/lib/rpm/redhat/macros rpm will not report an error.  I'm not how to
determine if this is a problem with brp-compress, my specfile or the mouseemu.8.
 After doing some research it does seem there has been problems with
brp-compress and man pages (though everything I found was from a few years back).

Version-Release number of selected component (if applicable):
8.0.45
Comment 1 Ben Konrath 2007-05-03 13:28:34 EDT
Reassigning to component owner.
Comment 2 Jeremy Katz 2007-06-19 14:18:24 EDT
It's just trying to compress the man page -- is it a broken link as opposed to
an actual file? 
Comment 3 Brenton Leanhardt 2007-06-20 08:30:29 EDT
My problem had to do with my lack up understanding the RPM system.  Here was my
specfile's %doc section:

%doc
%defattr(-,root,root,-)
/usr/share/man/man8/mouseemu.8

Since brp-compress compresses the man page I realized I had to list
"/usr/share/man/man8/mouseemu.8.gz" as the file RPM should look for. 

Note You need to log in before you can comment on or make changes to this bug.