Bug 238884 - RHEL5-based server hangs during warm reboot in QLogic HBA BIOS initialization
Summary: RHEL5-based server hangs during warm reboot in QLogic HBA BIOS initialization
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Mike Christie
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-03 16:57 UTC by Sidney Polyakoff
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version: 5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 22:24:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sidney Polyakoff 2007-05-03 16:57:35 UTC
Description of problem:

We've got 4way Opteron based server with QLA2362 HBA on board. Test installation
of RHEL5 on was successfull. Server boots up and qla2xxx loads up normally. But
next reboot fails because server hangs before kernel starts - during QLogic HBA
initialization phase. Server hangs right before HBA BIOS-concerned lines
appears. I.e. we can't see that lines. 
After this hang all we can do it's cold restart. 
Same server works and reboots well with RHEL4.2, RHEl4.3.


Version-Release number of selected component (if applicable):

Base RHEL5 kernel and drivers.

How reproducible:

Every warm reboot.

Steps to Reproduce:
1. Boot RHEL5
2. Load QLA driver
3. reboot
After that server hangs somewhere in BIOS initialisation.
  
Actual results:

Need cold restart to reboot.

Expected results:


Additional info:

Comment 1 Sidney Polyakoff 2007-05-03 17:00:40 UTC
Sorry, not QLA2362 but QLA2342

Comment 2 James Fillman 2007-05-14 19:17:34 UTC
This is happening to me as well, exactly as described in this bug. I'm running
on an IBM x336. 

Perhaps the firmware that the kernel module loads is causing problems??



Comment 3 Stefan Kaltenbrunner 2007-07-01 14:23:05 UTC
(In reply to comment #2)
> This is happening to me as well, exactly as described in this bug. I'm running
> on an IBM x336. 
> 
> Perhaps the firmware that the kernel module loads is causing problems??
> 
this problem is there with the upstream kernel too - we had similar problems
with IBM x336 boxes and other kernels (plain 2.6.15/2.6.16 and also the default
debian kernels) here too(and no useful help from IBM to fix it at the time).
You can try to upgrade your bios to the latest revision (1.13 might contain a
fix for that particular problem)
http://www-304.ibm.com/jct01004c/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-57354&brandind=5000008


Comment 4 Ernie Petrides 2007-09-11 21:15:04 UTC
There were two Qlogic driver updates during RHEL5.1 development (in kernel
versions 2.6.18-19.el5 and 2.6.18-27.el5).  Does the current RHEL5.1 beta
kernel resolve this problem?

Comment 5 Tom Coughlan 2007-11-21 22:24:23 UTC
No answer for two months. Closing. 


Note You need to log in before you can comment on or make changes to this bug.