Bug 23890 - When logging in /etc/profile and ~/.bash_profile are not being read to set the PATH
When logging in /etc/profile and ~/.bash_profile are not being read to set th...
Status: CLOSED DUPLICATE of bug 18225
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 11:12 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 23:07:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-12 11:12:14 EST
I have noticed this bug when using RedHat Linux 7.0 and logging in
graphically into KDE.

When looging into a virtual console(Ctrl + Alt +F1) and typing env, the
PATH that is listed matches the PATH statements whats in the /etc/profile
and ~/.bash_profile.

However, when logging in graphically, and using KDE(I haven't tested this
in GNOME), and dropping to a konsole, or terminal emulation, and typing
env, the PATH that is listed doesn't match what is in the /etc/profile and
~/.bash_profile. That is, the PATH that was listed by typing env, did not
contain the entries that were in /etc/prfofile and ~/.bash_profile and
there were extra entries listed that weren't even listed in these file or
the vitual console.

Examples/References:
This is the exact PATH statement that is listed when I login into a vitual
console(Ctrl + Alt + F1) and type in env:
PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/fred:/usr/local/sbin:/usr/sbin:/sbin:/root/bin:/johnny:/bob

These are the PATHs I see when in a GUI:
IN KDE, start various terminals and type env:
PATH=/usr/kerberos/sbin:/usr/kerberos/bin:~/bin:/bin:/usr/bin:/usr/X11R6/bin:/opt/kde2/bin:/usr/lib/kde2/bin:/usr/local/bin
<==> xterm
PATH=/usr/kerberos/sbin:/usr/kerberos/bin:~/bin:/bin:/usr/bin:/usr/X11R6/bin:/opt/kde2/bin:/usr/lib/kde2/bin:/usr/local/bin
<==> by right-clicking on the desktop, then clicking "Execute command" and
typing in: konsole %i %mi -caption "%c"
PATH=~/bin:/bin:/usr/bin:/usr/X11R6/bin:/opt/kde2/bin:/usr/lib/kde2/bin:/usr/local/bin
<==> clicking on the Terminal Emulation button on the kpanel, now in that
same terminal after typing env, type bashm then type env and the path it
gives you is:
PATH=/usr/kerberos/sbin:/usr/kerberos/bin:~/bin:/bin:/usr/bin:/usr/X11R6/bin:/opt/kde2/bin:/usr/lib/kde2/bin:/usr/local/bin

And these are what I actually have as a PATH statement in these two files:
/etc/profile
PATH="$PATH:/usr/X11R6/bin:/fred"

~/.bash_profile
PATH="$PATH:/usr/local/sbin:/usr/sbin:/sbin:/root/bin:/johnny:/bob"

So I'd like to point out that these PATH statements are being used in the
GUI, also that some extra paths that don't appear in these 2 files or in
the vitual console appear in the GUI such as /opt/kde2/bin and
/usr/lib/kde2/bin

P.S. about the component field. I didn't really know what this bug would
belong to, In the Component Test box I typed in: 
Either KDE, RedHat Linux, Konsole, or X
but It didn't like this.
Comment 1 Michael Schwendt 2001-01-12 23:07:04 EST
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=18225
Comment 2 Bernhard Rosenkraenzer 2001-01-15 16:28:31 EST

*** This bug has been marked as a duplicate of 18225 ***

Note You need to log in before you can comment on or make changes to this bug.