Bug 238917 - robust scriptlets
Summary: robust scriptlets
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fonts-hebrew-fancy   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dan Kenigsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 238851 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-03 20:31 UTC by Sebastian Vahl
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-14 13:09:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sebastian Vahl 2007-05-03 20:31:58 UTC
Description of problem: This packages uses fc-cache in %post. But it its not
requiring fontconfig.


Version-Release number of selected component (if applicable): 
fonts-hebrew-fancy-0.20051122-1.fc6


Additional info: Missing "Require: fontconfig" would produce an error when
creating a livecd with livecd-tools. fonts-hebrew-fancy would be installed
before fontconfig. So the scriplet would fail because fc-cache is not available
at this time.

Comment 1 Rex Dieter 2007-05-05 21:13:42 UTC
No. 

Per
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#fonts

just add checks to the scriptlets to make them robust (ie, not produce errors on
missing fc-cache).

Comment 2 Karsten Hopp 2007-05-14 12:19:10 UTC
*** Bug 238851 has been marked as a duplicate of this bug. ***

Comment 3 Rex Dieter 2007-05-14 13:09:20 UTC
%changelog
* Mon May 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.20051122-2
- robust scriptlets (#238917)




Note You need to log in before you can comment on or make changes to this bug.