Bug 23898 - IBM's Visual Age for Java Fails to Start
IBM's Visual Age for Java Fails to Start
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 12:36 EST by Bill Chatfield
Modified: 2016-11-24 10:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 05:20:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vaj.log (22.50 KB, text/plain)
2001-01-15 10:16 EST, Bill Chatfield
no flags Details
vaj.log.31705 (18.50 KB, text/plain)
2001-01-15 10:17 EST, Bill Chatfield
no flags Details
vaj.log.31706 (33.10 KB, text/plain)
2001-01-15 10:17 EST, Bill Chatfield
no flags Details
vaj.log.31707 (685 bytes, text/plain)
2001-01-15 10:18 EST, Bill Chatfield
no flags Details
vaj.log.31708 (217.01 KB, text/plain)
2001-01-15 10:19 EST, Bill Chatfield
no flags Details

  None (edit)
Description Bill Chatfield 2001-01-12 12:36:53 EST
Both version 3.0 and version 3.02 of IBM's Visual Age for Java (VAJ) for 
Linux fail to start and display the same error when you start them.  It 
includes a "general protection fault".  I'll add the exact error and an 
strace later when I can get back to my Linux machine.

These versions of VAJ worked correctly in RHL 6.2.  I'm guessing the 
problem is with glibc because that's where most of the other problems like 
this have been.  I'm suprised that IBM has not yet reported this.

I have installed all updates to RHL7 as of Jan 11, 2001 and the problem 
still occurs.

Both VAJ for Linux 3.0 and the 3.02 update are downloadable from IBM's web 
site.  You have to be a member of the Visual Age Developer's Domain(?) 
which is free.

I have specified the priority and severity as high because VAJ is a very 
important commercial product from IBM that is used for web site 
developement: servlets, JavaBeans, EJB.  It is one of the best software 
development tools available on Linux and I consider it to be a serious 
problem when RHL does not run it.
Comment 1 Jakub Jelinek 2001-01-12 13:49:10 EST
Do you have glibc-2.2-12 installed or not?
It works around a bug in IBM JDK.
Comment 2 Bill Chatfield 2001-01-12 22:35:22 EST
I do have glibc-2.2-12 installed.  I can run IBM's JDK 1.1.8, but I still can't
run VAJ.  I believe VAJ is a C program, although it would run a JVM when you
tell it to run your Java program.  I think, during startup, it would only be
running compiled C code.  At least that's what I've been led to believe.

I have a dual processor machine, if that makes any difference.

Here's the strace, which includes the error message in the output.  This is
where it just stops.  I can't do a Ctrl-C to kill it.  I have to do a Ctrl-Z and
then a kill %1 to kill it.

Unfortunately, this appears to just be showing that it's starting another
program and waiting for it.  The problem is in the "ide" program that it's
starting, apparently.  I'll see if I can figure out how to get to generate an
strace for that.

stat("./ide/program", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
rt_sigprocmask(SIG_BLOCK, [CHLD TTOU], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
rt_sigprocmask(SIG_BLOCK, [CHLD TTOU], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
rt_sigprocmask(SIG_BLOCK, [CHLD TTOU], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
stat("/home/bchat/opt/VisualAge/.", {st_mode=S_IFDIR|0775, st_size=4096, ...}) =
0
chdir("/home/bchat/opt/VisualAge/ide/program") = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
rt_sigprocmask(SIG_BLOCK, [CHLD TTOU], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
stat(".", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat(".", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("./ide", {st_mode=S_IFREG|0755, st_size=3147589, ...}) = 0
stat("./ide", {st_mode=S_IFREG|0755, st_size=3147589, ...}) = 0
rt_sigprocmask(SIG_BLOCK, ~[], [], 8)   = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [INT CHLD], [], 8) = 0
_llseek(255, -9, [327], SEEK_CUR)       = 0
fork()                                  = 1272
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGINT, {0x806f120, [], 0x4000000}, {SIG_DFL}, 8) = 0
wait4(-1, 
VisualAge for Java
(c) Copyright IBM Corp. 1991, 1999

Startup Diagnostics:

1) Primitive failed in: PlatformFunction>>#callWith:with:with:with:with:with:
due to General protection fault
2) Primitive failed in: PlatformFunction>>#callWith:with:with:with:with:with:
due to General protection fault

Comment 3 Jakub Jelinek 2001-01-15 06:50:29 EST
You can run strace -ff -o /tmp/vaj.log to see traces of children as well.
Comment 4 Bill Chatfield 2001-01-15 10:16:15 EST
Created attachment 7608 [details]
vaj.log
Comment 5 Bill Chatfield 2001-01-15 10:17:20 EST
Created attachment 7609 [details]
vaj.log.31705
Comment 6 Bill Chatfield 2001-01-15 10:17:54 EST
Created attachment 7610 [details]
vaj.log.31706
Comment 7 Bill Chatfield 2001-01-15 10:18:54 EST
Created attachment 7611 [details]
vaj.log.31707
Comment 8 Bill Chatfield 2001-01-15 10:19:36 EST
Created attachment 7612 [details]
vaj.log.31708
Comment 9 Bill Chatfield 2001-01-15 10:27:25 EST
I've attached all the strace log files that the following command produces
during one invocation.

strace -ff -o /tmp/vaj.log ./vajide

It appears to fork 5 other processes.  The fifth was 31710, but the strace log
file was empty so it wouldn't attach.

Unfortunately, I couldn't see from the straces what the problem is.  I didn't
look at it carefully because I don't have time this morning.  Maybe you can see
where the problem is.

If there's anything else I can do to help determine what the problem is, let me
know.  I'll work on it when I get back home tonight.

Comment 10 Ulrich Drepper 2003-10-03 05:20:34 EDT
Pretty late reply but we couldn't have said more at that time.  This is a 3rd
party app, and a multi-threaded one.  The odds are that the IDE is at fault.  I
guess that meanwhile there are new versions available.  So I close this bug
because it's not of interest anymore.  Reopen if you must.

Note You need to log in before you can comment on or make changes to this bug.