Bug 239000 - pax fails creation of ustar if an absolute name is exactly 100 characters long
pax fails creation of ustar if an absolute name is exactly 100 characters long
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pax (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Ben Levenson
:
Depends On:
Blocks: 239001
  Show dependency treegraph
 
Reported: 2007-05-04 08:21 EDT by Martin Poole
Modified: 2010-10-22 10:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 569323 (view as bug list)
Environment:
Last Closed: 2010-03-19 08:17:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar file with absolute names of varying lengths to illustrate problem/test solution. (4.00 KB, application/x-tar)
2007-05-04 08:21 EDT, Martin Poole
no flags Details
patch to fix absolute 100 char file issue (670 bytes, patch)
2007-05-04 08:23 EDT, Martin Poole
no flags Details | Diff

  None (edit)
Description Martin Poole 2007-05-04 08:21:06 EDT
Description of problem:

If pax attempts to create a ustar format archive with absolute path names it
fails on paths that are exactly 100 characters long. Where the length is <100 or
101-254 it works.

Version-Release number of selected component (if applicable):

pax-3.0-9

How reproducible:

always

Steps to Reproduce:
1. unpack the attached tar with    tar -x -C / -f pax_abs_test.tar
2. pax -w -f /var/tmp/px.tar /var/tmp/pax_abs_test -x ustar
3.
  
Actual results:
pax: File name too long for ustar
/var/tmp/pax_abs_test/this_file_fails_because_the_absolute_filename_is_exactly__100__characters_long


Expected results:

no errors, complete tar.

Additional info:

The pax source contains a specific mention of the boundary condition where the
name is of the form /str and 100 characters long and errs on the side of
absolute posix adherence. What it fails to account for is when the name is of
the form /dir/str and the length is 100 characters. In this situation it would
be valid to perform the normal split procedure as long as the split is not at
the first character.
Comment 1 Martin Poole 2007-05-04 08:21:07 EDT
Created attachment 154110 [details]
tar file with absolute names of varying lengths to illustrate problem/test solution.
Comment 2 Martin Poole 2007-05-04 08:23:21 EDT
Created attachment 154111 [details]
patch to fix absolute 100 char file issue
Comment 3 RHEL Product and Program Management 2008-02-01 14:08:29 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Ondrej Vasik 2010-03-19 08:17:22 EDT
As RHEL-4.9 is last update for RHEL-4 and it is not suitable for new features
and should address only security, performance and critical issues, I'm closing
that bugzilla WONTFIX. Problem is fixed in RHEL-5.

Note You need to log in before you can comment on or make changes to this bug.