Bug 239001 - pax fails creation of ustar if an absolute name is exactly 100 characters long
pax fails creation of ustar if an absolute name is exactly 100 characters long
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pax (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Ben Levenson
: Reopened
: 569323 (view as bug list)
Depends On: 239000
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-04 08:29 EDT by Martin Poole
Modified: 2013-04-12 15:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-18 05:10:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar file with absolute names of varying lengths to illustrate problem/test solution. (4.00 KB, application/x-tar)
2007-05-04 08:30 EDT, Martin Poole
no flags Details
patch to fix absolute 100 char file issue (670 bytes, patch)
2007-05-04 08:30 EDT, Martin Poole
no flags Details | Diff

  None (edit)
Description Martin Poole 2007-05-04 08:29:11 EDT
+++ This bug was initially created as a clone of Bug #239000 +++

Description of problem:

If pax attempts to create a ustar format archive with absolute path names it
fails on paths that are exactly 100 characters long. Where the length is <100 or
101-254 it works.

Version-Release number of selected component (if applicable):

pax-3.4-1.2.2

How reproducible:

always

Steps to Reproduce:
1. unpack the attached tar with    tar -x -C / -f pax_abs_test.tar
2. pax -w -f /var/tmp/px.tar /var/tmp/pax_abs_test -x ustar
3.
  
Actual results:
pax: File name too long for ustar
/var/tmp/pax_abs_test/this_file_fails_because_the_absolute_filename_is_exactly__100__characters_long


Expected results:

no errors, complete tar.

Additional info:

The pax source contains a specific mention of the boundary condition where the
name is of the form /str and 100 characters long and errs on the side of
absolute posix adherence. What it fails to account for is when the name is of
the form /dir/str and the length is 100 characters. In this situation it would
be valid to perform the normal split procedure as long as the split is not at
the first character.

-- Additional comment from mpoole@redhat.com on 2007-05-04 08:21 EST --
Created an attachment (id=154110)
tar file with absolute names of varying lengths to illustrate problem/test solution.


-- Additional comment from mpoole@redhat.com on 2007-05-04 08:23 EST --
Created an attachment (id=154111)
patch to fix absolute 100 char file issue
Comment 1 Martin Poole 2007-05-04 08:30:10 EDT
Created attachment 154112 [details]
tar file with absolute names of varying lengths to illustrate problem/test solution.
Comment 2 Martin Poole 2007-05-04 08:30:45 EDT
Created attachment 154113 [details]
patch to fix absolute 100 char file issue
Comment 3 RHEL Product and Program Management 2007-06-05 16:28:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 5 Radek Brich 2007-06-20 05:46:54 EDT
patch added to rawhide
Comment 7 RHEL Product and Program Management 2007-12-03 15:42:35 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 8 RHEL Product and Program Management 2008-07-21 19:11:16 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 16 errata-xmlrpc 2009-11-18 05:10:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1591.html
Comment 17 Ondrej Vasik 2010-10-11 09:51:16 EDT
*** Bug 569323 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.