Bug 239018 - /etc/login.defs overwrites customer config
Summary: /etc/login.defs overwrites customer config
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: shadow-utils (Show other bugs)
(Show other bugs)
Version: 4.5
Hardware: All Linux
high
high
Target Milestone: ---
: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-04 13:46 UTC by Calvin Smith
Modified: 2018-10-19 19:58 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0832
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:08:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0832 normal SHIPPED_LIVE shadow-utils bug fix update 2007-11-14 18:37:21 UTC

Description Calvin Smith 2007-05-04 13:46:19 UTC
Description of problem:
If you have made changes to the /etc/login.defs configuration file, shadow-utils
4.0.3-61 will not install unless you use the up2date -f option and then it
overwrites the already installed version of the login.defs file.

Version-Release number of selected component (if applicable):
4.0.3-61

How reproducible:
always

Steps to Reproduce:
1. modify /etc/login.defs
2. up2date -uf shadow-utils
3. 
  
Actual results:
the old /etc/login.defs is moved to /etc/login.defs.rpmsave and the new
/etc/login.defs replaces it.

Expected results:
the new /etc/login.defs should be saved to /etc/login.defs.rpmnew

Additional info:

Comment 1 Peter Vrabec 2007-05-14 13:35:11 UTC
login.defs should be marked as noreplace. This problem is fixed since 
shadow-utils-4.0.16-1. bz. #190014.


Comment 2 Calvin Smith 2007-05-14 13:56:30 UTC
I found that bug, but it doesn't seem as though the fix was backported into the
RHEL 4 tree.

Comment 4 RHEL Product and Program Management 2007-06-26 15:25:40 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 17 errata-xmlrpc 2007-11-15 16:08:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0832.html



Note You need to log in before you can comment on or make changes to this bug.