Bug 23906 - PATCH: print both IPv6 and IPv4 routing tables if IPv6 loaded
Summary: PATCH: print both IPv6 and IPv4 routing tables if IPv6 loaded
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-tools   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-12 19:56 UTC by Pekka Savola
Modified: 2015-03-05 01:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-08 12:55:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
show both ipv6 and ipv4 routing tables if IPv6 is enabled (2.21 KB, patch)
2001-01-12 19:56 UTC, Pekka Savola
no flags Details | Diff

Description Pekka Savola 2001-01-12 19:56:04 UTC
Here's a small patch I cooked up because I like how BSD shows IPv6.

By default you have to specify '-A inet6' to see IPv6 routes, connections or anything.

With this, netstat -r and route print out both routing tables by default _IF_ you have
IPv6 kernel module loaded (check for /proc/net/ipv6_route); else, only IPv4 is printed.

Comment 1 Pekka Savola 2001-01-12 19:56:55 UTC
Created attachment 7527 [details]
show both ipv6 and ipv4 routing tables if IPv6 is enabled

Comment 2 Pekka Savola 2001-04-19 19:02:55 UTC
This patch is a bit controversial as ipv6 printing hasn't been optimized so it always wraps lines.

On BSD, where the idea is from, one route 99% only takes one line.

Comment 3 Phil Knirsch 2002-04-08 12:55:00 UTC
Has this patch made it into the official upstream release of iputils? If so we
can close this bug as the latest iputils package is now based on the latest
upstream release.

Read ya, Phil

Comment 4 Pekka Savola 2002-04-10 06:35:19 UTC
Nope..

In any case the output of the IPv6 route command should be textually compressed
before this would be feasible, as currently a line wrap happens.

Before this is done, I'm not sure how sensible this is, so closing as WONTFIX..


Note You need to log in before you can comment on or make changes to this bug.