Bug 239120 - smart fails to recognize 1 of a pair of identical disks
smart fails to recognize 1 of a pair of identical disks
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Smetana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-04 20:40 EDT by Tom Horsley
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-13 04:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/smartd.conf file (3.16 KB, text/plain)
2007-05-07 06:01 EDT, Tom Horsley
no flags Details
smartctl -i /dev/sda (625 bytes, text/plain)
2007-05-07 06:02 EDT, Tom Horsley
no flags Details
smartctl -i /dev/sdb (625 bytes, text/plain)
2007-05-07 06:03 EDT, Tom Horsley
no flags Details
smartctl -a /dev/sda (4.51 KB, text/plain)
2007-05-07 17:18 EDT, Tom Horsley
no flags Details
smartctl -a /dev/sdb (4.51 KB, text/plain)
2007-05-07 17:20 EDT, Tom Horsley
no flags Details
the error from boot time smartctl -i (948 bytes, text/plain)
2007-05-07 17:31 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2007-05-04 20:40:45 EDT
Description of problem:

In fc7t4, the "smart" tools are kinda stoopid instead :-). Two absolutely
identical SAMSUNG HD160JJ "Spinpoint" 160gig sata drives in the system.
FC6 smart sees them both, fc7 smart claims /dev/sda doesn't support smart:

Apr 27 21:15:40 zooty smartd[2844]: smartd version 5.37
[x86_64-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen 
Apr 27 21:15:40 zooty smartd[2844]: Home page is
http://smartmontools.sourceforge.net/  
Apr 27 21:15:40 zooty smartd[2844]: Opened configuration file /etc/smartd.conf 
Apr 27 21:15:40 zooty smartd[2844]: Configuration file /etc/smartd.conf parsed. 
Apr 27 21:15:40 zooty smartd[2844]: Device: /dev/sdb, opened 
Apr 27 21:15:40 zooty smartd[2844]: Device: /dev/sdb, found in smartd database. 
Apr 27 21:15:40 zooty smartd[2844]: Device: /dev/sdb, is SMART capable. Adding
to "monitor" list. 
Apr 27 21:15:40 zooty smartd[2844]: Device: /dev/sda, opened 
Apr 27 21:15:40 zooty smartd[2844]: Device: /dev/sda, found in smartd database. 
Apr 27 21:15:41 zooty smartd[2844]: Device: /dev/sda, not capable of SMART
Health Status check 
Apr 27 21:15:41 zooty smartd[2844]: Unable to register ATA device /dev/sda at
line 33 of file /etc/smartd.conf 
Apr 27 21:15:41 zooty smartd[2844]: Device /dev/sda not available 
Apr 27 21:15:41 zooty smartd[2844]: Monitoring 1 ATA and 0 SCSI devices 
Apr 27 21:15:41 zooty smartd[2846]: smartd has fork()ed into background mode.
New PID=2846. 


Version-Release number of selected component (if applicable):
smartmontools-5.37-2.fc7

How reproducible:
every time I boot

Steps to Reproduce:
1. boot system
2. see error in /var/log/messages
3. see that hddtemp is unable to monitor /dev/sda
  
Actual results:


Expected results:


Additional info:
Comment 1 Dennis Jacobfeuerborn 2007-05-05 10:06:12 EDT
I'm seeing the same problem with my two Samsung drives:

ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: ATA-8: SAMSUNG HD403LJ, CT100-10, max UDMA7
ata1.00: 781422768 sectors, multi 16: LBA48 NCQ (depth 0/32)
ata1.00: configured for UDMA/133
scsi1 : sata_nv
ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata2.00: ATA-8: SAMSUNG HD403LJ, CT100-10, max UDMA7
ata2.00: 781422768 sectors, multi 16: LBA48 NCQ (depth 0/32)
ata2.00: configured for UDMA/133
scsi 0:0:0:0: Direct-Access     ATA      SAMSUNG HD403LJ  CT10 PQ: 0 ANSI: 5
SCSI device sda: 781422768 512-byte hdwr sectors (400088 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
SCSI device sda: 781422768 512-byte hdwr sectors (400088 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
 sda: sda1 sda2 sda3 sda4 < sda5 >
sd 0:0:0:0: Attached scsi disk sda
scsi 1:0:0:0: Direct-Access     ATA      SAMSUNG HD403LJ  CT10 PQ: 0 ANSI: 5
SCSI device sdb: 781422768 512-byte hdwr sectors (400088 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
SCSI device sdb: 781422768 512-byte hdwr sectors (400088 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
 sdb: sdb1 sdb2 sdb3 sdb4 < sdb5 >
sd 1:0:0:0: Attached scsi disk sdb
Comment 2 Tomas Smetana 2007-05-07 03:15:54 EDT
Could you please attach your /etc/smartd.conf file and output of "smartctl -i
/dev/sda" and "smartctl -i /dev/sdb" commands?
Comment 3 Tom Horsley 2007-05-07 06:01:26 EDT
Created attachment 154247 [details]
/etc/smartd.conf file

Looks like it didn't like the disk at the time it first created
the smartd.conf file, but as the next attachment will show, it
likes it find once the system is up and running.
Comment 4 Tom Horsley 2007-05-07 06:02:23 EDT
Created attachment 154248 [details]
smartctl -i /dev/sda

This is the one it claims had an error.
Comment 5 Tom Horsley 2007-05-07 06:03:07 EDT
Created attachment 154249 [details]
smartctl -i /dev/sdb

This is the one that always worked fine.
Comment 6 Tomas Smetana 2007-05-07 08:28:14 EDT
Thanks. The interesting thing is that the identical disks report different
capabilities (and since hda states it does not support the only test asked in
cofiguration it gets unregistered).

Have you tried to use only DEVICESCAN in the /etc/smartd.conf? Also you may try
to run "smartctl -a" on both disks and verify they report the same capabilities.
Comment 7 Tom Horsley 2007-05-07 17:17:19 EDT
Actually the identical disks only report different capabilities at the time
smartd start up and autogenerates the config file during boot. If I stop
the smartd service and start it again after the system is up and I've logged in,
it comes up with a different config file, this one says it is monitoring
both sda and sdb. Smart is already the last thing that happens in the boot,
so I don't know how it could not be ready yet, but something mysterious
is going on. I'm attaching the smartctl -a listings for both disks that show
they are indeed near identical.
Comment 8 Tom Horsley 2007-05-07 17:18:56 EDT
Created attachment 154298 [details]
smartctl -a /dev/sda

This is the one it claims doesn't work during autogeneration of
/etc/smartd.conf
at boot time.
Comment 9 Tom Horsley 2007-05-07 17:20:01 EDT
Created attachment 154299 [details]
smartctl -a /dev/sdb

This is the one that always works.
Comment 10 Tom Horsley 2007-05-07 17:31:29 EDT
Created attachment 154300 [details]
the error from boot time smartctl -i

Out of curiosity, I hacked the /etc/rc.d/init.d/smartd file and added
an explicit smartctl -i /dev/sda command, and this shows the error
it prints when run at boot time (the autogeneration that happened
right after this still failed, so running it once isn't enough to flush
whatever error state seems to exist at boot time).
Comment 11 Tomas Smetana 2007-05-14 07:31:48 EDT
I still can't reproduce this... I'm trying to find the same Samsung disks
somewhere around. Any other devices work fine.
Comment 12 Tomas Smetana 2007-07-13 04:10:44 EDT
Sorry. I can't reproduce the problem.

Note You need to log in before you can comment on or make changes to this bug.