Bug 239177 - OOCalc takes too long to open a file when default printer server is unavailable
Summary: OOCalc takes too long to open a file when default printer server is unavailable
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-05 16:33 UTC by Laurent Aguerreche
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 08:18:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 34140 None None None Never
OpenOffice.org 65739 None None None Never

Description Laurent Aguerreche 2007-05-05 16:33:12 UTC
Description of problem:
OOCalc takes too long to open a file because it is waiting for an IPP answer.

How reproducible:
Use a laptop or at least a computer that will not be able to access server given
in client.conf for CUPS.
Then when OOCalc will open a file it will try to send a SYN_SENT packet to the
previous given server and wait... It can wait 2 or 3 minutes (I did not mesure
it exactly) before continue to try to open given file. 


Steps to Reproduce:
1. Use a computer that can not access server given in client.conf for CUPS.
2. Run OOCalc with a file to open as parameter, or run OOCalc and then try to
open a file.
3. Now OCCalc seems to hang...
4. Run lsof and see something like:
  "scalc.bin 13966  my_login   35u     IPv4     181430                 TCP
my_IP:50133->print.a_server.com:ipp (SYN_SENT)"
  
Actual results:
I am waiting too long when I want to open a file in OOCalc.

Expected results:
File should be opened immediatly.
I do not understand why OOcalc sends a packet when it starts... Why not only
when user needs to print something?
Timeout for SYN_SENT packet should be smaller.

Additional info:
No problem found with OOWriter.

Comment 1 Caolan McNamara 2007-05-08 08:15:31 UTC
to get the printer metrics for best fit WYSIWYG layout.

Comment 2 Caolan McNamara 2007-05-08 08:18:44 UTC
what we need is to add an option to calc like writer which is "use printer
metrics" (there is such an option in calc, but it is not the same as the writer
one, http://qa.openoffice.org/issues/show_bug.cgi?id=65739) and then default
that option to off which would then mean that we don't have to query the printer
for it's metrics in calc when starting up, avoiding this problem


Note You need to log in before you can comment on or make changes to this bug.