Bug 239183 - doesn't build on ppc64
Summary: doesn't build on ppc64
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: beryl-core   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-05 19:04 UTC by Bill Nottingham
Modified: 2014-03-17 03:06 UTC (History)
2 users (show)

Fixed In Version: 0.2.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 13:25:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2007-05-05 19:04:28 UTC
It claims libdrm isn't available there - as far as I can tell, it is.

Comment 1 Jarod Wilson 2007-05-11 21:03:34 UTC
Hrm... So libdrm-devel.ppc64 is indeed available, but freeglut-devel.ppc64
isn't. That ExcludeArch stuff was heisted from the compiz spec, so I blame krh... :)

Not sure if that's the only problem, but the build definitely blows up right
now. Do we really care about building this for ppc64, especially since beryl is
supposed to be merging back with compiz? I'm inclined to close WONTFIX right now...

Comment 2 Bill Nottingham 2007-05-11 21:58:12 UTC
freeglut should be there, in any case. It doesn't *need* to be fixed, but if
it's not, beryl-* from extras needs to get the same excludearch.

Comment 3 Jarod Wilson 2007-06-04 21:34:31 UTC
Forthcoming beryl-core 0.2.1 built fine locally on a ppc64 system after some
tweaking.

Comment 4 Jarod Wilson 2007-06-05 15:34:25 UTC
And now its built for f7 and devel. Dependent bits to follow...

Comment 5 Fedora Update System 2007-06-06 16:42:16 UTC
beryl-core-0.2.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2007-06-16 13:25:13 UTC
beryl-core-0.2.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.