Bug 239230 - pg_hba.conf.sample not a valid config file, has @...@
pg_hba.conf.sample not a valid config file, has @...@
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-06 11:27 EDT by Jon Burgess
Modified: 2013-07-02 23:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-06 11:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Burgess 2007-05-06 11:27:53 EDT
Description of problem:
/usr/share/pgsql/pg_hba.conf.sample contains text like "@authcomment@" looks
like it is intended that this file should be run through some template process

Version-Release number of selected component (if applicable):
postgresql-server-8.2.3-2.fc7

How reproducible:
Every time

Steps to Reproduce:
1. grep \@ /usr/share/pgsql/pg_hba.conf.sample
2.
3.
  
Actual results:
[root@shark local]# grep \@ /usr/share/pgsql/pg_hba.conf.sample
# you can also write a file name prefixed with "@" to include names from
@authcomment@
@remove-line-for-nolocal@# "local" is for Unix domain socket connections only
@remove-line-for-nolocal@local   all         all                              
@authmethod@
host    all         all         127.0.0.1/32          @authmethod@
host    all         all         ::1/128               @authmethod@


Expected results:
I think the @authmethod@ etc strings are expected to be replaced by something
else (e.g. they used to be "ident sameuser" in fc6).

Additional info:
Comment 1 Jon Burgess 2007-05-06 11:31:28 EDT
Forget about this, it looks like the initdb code replaces these tokens.

Note You need to log in before you can comment on or make changes to this bug.