Bug 239245 - Dell e1505 / MM061 laptop restores to empty black screen from suspend
Dell e1505 / MM061 laptop restores to empty black screen from suspend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: HardwareEnablement, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-06 17:10 EDT by Jens Knutson
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 02:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Knutson 2007-05-06 17:10:02 EDT
Description of problem:
When trying to restore from suspend, my Dell e1505 / MM061 (the latter code is
what hal reports as "system.hardware.product"), I get a plain black screen. 
When in this screen, the keyboard is non-responsive - Ctrl Alt Del does nothing,
and I am forced to hold down the pwr button for 5 secs to force shutdown.


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.0.0-2.fc7
(I filed this bug against the X driver as a best guess.)

How reproducible:
100%

Steps to Reproduce:
1. Suspend laptop
2. Restore laptop
3. Stare angrily at empty black screen, be forced to perform hard shutdown

Additional info:
This is a regression from FC6, where it worked perfectly.
Comment 1 Oleg Drokin 2007-05-14 15:18:34 EDT
I'd probably join this report (amongst quite a few similar ones).
suspend2RAM worked quite well in FC6, but after I upgraded to FC7beta4, I got
black screen & dead system on resume.
Now after updating my kernel to 2.6.21-1.3142.fc7 today, I cannot even suspend
anymore, machine freezes after printing Suspending Console(s).
Booting into 2.6.20-1.2944.fc6 makes suspend usable again, of course.
Comment 2 Oleg Drokin 2007-05-14 15:21:46 EDT
Hm, component in this bug is obviously wrong, because the problem is definitely
in kernel. and I clearly can reproduce without any sort of X environment
running, unfortunatelly I am not allowed to change it.
(also I have Dell Latitude D620 Core2Duo system, which I forgot to say earlier)
Comment 3 Jens Knutson 2007-05-14 16:53:52 EDT
Thanks for the tip, Oleg!  I've changed the bug accordingly.

Also, as of 2.6.21-1.3149.fc7, I get the same problem as Oleg.  I can't even
suspend, much less restore - it gets stuck at "Suspending Console(s)", just as
he described.
Comment 4 Richard Hughes 2007-05-24 06:44:12 EDT
Can you try the steps at http://people.freedesktop.org/~hughsient/quirk/ and see
if you need to blaklist a module. Thanks!
Comment 5 Jens Knutson 2007-07-19 02:15:54 EDT
WOOHOO!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ok, I'm just a little excited.  *cough*

Using the git hal-info vid quirks file for my laptop, everything works 100% with
kernel-2.6.23-0.30.rc0.git6.fc8

Everything.  No hacks.  No blacklisting.  Nothing.  It just WORKS.... like in
FC6. ;-)

Closing, RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.