Bug 239257 - RAID partitions not initialized on startup
RAID partitions not initialized on startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-07 00:20 EDT by Ulrich Drepper
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:13:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2007-05-07 00:20:38 EDT
Description of problem:
I have two RAID partitions which mdadm is supposed to initialize early on in
rc.sysinit.  This does not succeed and therefore later the fsck calls fail and
throw me in the panic shell.  Booting with enforcing=0 makes things work.


Version-Release number of selected component (if applicable):
initscripts-8.53-1.x86_64
selinux-policy-2.6.1-1.fc7.noarch
mdadm-2.6.1-4.fc7.x86_64

How reproducible:
always


Steps to Reproduce:
1.boot system with RAID partitions
2.
3.
  
Actual results:
RAID not initialized

Expected results:
RAID initialized, partitions can be mounted

Additional info:
I don't have the audit message since it's not printed on the console.
Comment 1 Bill Nottingham 2007-05-07 16:46:40 EDT
Can you replace the call to mdadm in /etc/rc.sysinit with:

strace /sbin/mdadm ...
bash

just to get an idea of where it fails?
Comment 2 Daniel Walsh 2007-07-16 16:31:55 EDT
There was a bug where mdadm was not allowed to create devices in /dev and then
use them. This should be fixed in the updated selinux policies so I think this
is fixed.
Comment 3 Daniel Walsh 2007-08-22 10:13:58 EDT
Should be fixed in the current release

Note You need to log in before you can comment on or make changes to this bug.