Bug 239276 - System-config-cluster does not update cluster name/alias properly
System-config-cluster does not update cluster name/alias properly
Status: CLOSED NOTABUG
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On: 210733
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-07 07:17 EDT by Martin von Weissenberg
Modified: 2009-04-16 16:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 04:12:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin von Weissenberg 2007-05-07 07:17:11 EDT
Description of problem:
The default name for new clusters in system-config-cluster is "alpha_cluster".
If the user changes the cluster name together with other parameters and
attributes, the cluster will NOT work because of naming problems. However if you
create a new cluster and immediately save, close and reopen it before doing any
changes, it seems to work.

Version-Release number of selected component (if applicable):
system-config-cluster-1.0.27-1.0.noarch

+++ This bug was initially created as a clone of Bug #210733 +++
Comment 2 Jim Parsons 2008-04-29 04:12:04 EDT
If the cluster has already been created, the name cannot be changed without
tearing down the cluster and starting over. This is why the cluster alias is
available. Truly, the actual name of the cluster is of little importance to the
running cluster. Only when creating a GFS share is the true name used.

System-config-cluster does not create a cluster. It can only create a new
cluster.conf file, and edit a conf file for a running cluster. Conga can be used
to create clusters.

In the above description, when saving, closing, and reopening...the conf file is
not being actually propogated. 

Note You need to log in before you can comment on or make changes to this bug.