Bug 239312 - Makefile.common new-source target gives cryptic error message when cert is expired
Makefile.common new-source target gives cryptic error message when cert is ex...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-07 10:57 EDT by Ray Strode [halfline]
Modified: 2013-01-09 20:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 18:03:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2007-05-07 10:57:20 EDT
(filing against koji since there is no common component)

I guess I haven't used my fedora cert in a year or so.  Anyway, it was expired
and when I tried to do a gnome-games upload I got this message:

$ make new-source FILES="gnome-games-2.18.1.1.tar.bz2"

Checking : gnome-games-2.18.1.1.tar.bz2 on
https://cvs.fedora.redhat.com/repo/pkgs/upload.cgi...
ERROR: could not check remote file status
make: *** [new-source] Error 255

I had no idea what was going on, so I finally ran:

$ curl -k --cert ${HOME}/.fedora.cert --fail  -F "name=gnome-games" -F
"md5sum=3e7dedf811f952efe8a32a7ceae8a32a7cea790a09" -F
"filename=gnome-games-2.18.1.1.tar.bz2"
https://cvs.fedora.redhat.com/repo/pkgs/upload.cgi
curl: (52) SSL read: error:14094415:SSL routines:SSL3_READ_BYTES:sslv3 alert
certificate expired, errno 0

and discovered my cert was expired.  It should give a better error message.

(then I hit bug 239309)
Comment 1 Jesse Keating 2007-05-22 18:03:21 EDT
I do believe a fix went into Makefile.common to check for this.

Note You need to log in before you can comment on or make changes to this bug.