Bug 239340 - nfsv4 acl use causes panic [NEEDINFO]
nfsv4 acl use causes panic
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-07 14:05 EDT by Dan Muntz
Modified: 2014-06-02 09:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
steved: needinfo? (dmuntz)
pm-rhel: needinfo? (dmuntz)


Attachments (Terms of Use)

  None (edit)
Description Dan Muntz 2007-05-07 14:05:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; (R1 1.5); .NET CLR 2.0.50727)

Description of problem:
Execution of a script (below) that does repeated nfsv4 setacls causes a panic.
Reproducible on RHEL5 base install, also the 2.6.18-8.1.3el5 kernel, and a 2.6.21.1 kernel from kernel.org.

The script loops 180 times.  If you step through one iteration at a time, the panic occurs on the 165th iteration.  There's some delay before the panic, so just letting the script run, it will complete, but the panic occurs after completion.

/mnt/tmp/acl is an nfsv4 mount, nfs4_setfacl is the command from CITI's utils for using nfsv4 acls directly.

#!/bin/bash
VAL=180
while [[ $VAL -gt 0 ]];
do
        echo $VAL
        nfs4_setfacl -a 'A::OWNER@:rwatTnNcCy' 5 /mnt/tmp/acl/myfile1
        VAL=`expr $VAL - 1`
done


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Run the included script

Actual Results:
Stack trace:
May 3 16:42:10 dm02 kernel: Bad page state in process 'swapper'
May 3 16:42:10 dm02 kernel: page:c160fe20 flags:0x80000080 mapping:00000000 mapcount:0 count:0 (Not tainted)
May 3 16:42:10 dm02 kernel: Trying to fix it up, but a reboot is needed
May 3 16:42:10 dm02 kernel: Backtrace:
May 3 16:42:10 dm02 kernel: [<c04536c9>] bad_page+0x4a/0x71
May 3 16:42:10 dm02 kernel: [<c04539cd>] free_hot_cold_page+0x63/0x103
May 3 16:42:10 dm02 kernel: [<c059f963>] skb_release_data+0x4c/0x7e
May 3 16:42:10 dm02 kernel: [<c059f77c>] kfree_skbmem+0x8/0x61
May 3 16:42:10 dm02 kernel: [<c05cad0e>] tcp_ack+0x639/0x16c9
May 3 16:42:10 dm02 kernel: [<c05ce945>] tcp_rcv_established+0x4b4/0x7c3
May 3 16:42:10 dm02 kernel: [<c041dc2f>] try_to_wake_up+0x371/0x37b
May 3 16:42:10 dm02 kernel: [<c05d3b0b>] tcp_v4_do_rcv+0x25/0x2bc
May 3 16:42:10 dm02 kernel: [<c05d5fdc>] tcp_v4_rcv+0x8dd/0x931
May 3 16:42:10 dm02 kernel: [<c041c408>] __wake_up_common+0x2f/0x53
May 3 16:42:10 dm02 kernel: [<c05bdf28>] ip_local_deliver+0x159/0x205
May 3 16:42:10 dm02 kernel: [<c05bdd95>] ip_rcv+0x3ef/0x429
May 3 16:42:10 dm02 kernel: [<c05a3989>] netif_receive_skb+0x2c1/0x339
May 3 16:42:10 dm02 kernel: [<f8905c41>] e1000_clean_rx_irq+0x3ef/0x49b [e1000]
May 3 16:42:10 dm02 kernel: [<f89043c5>] e1000_clean+0x69/0x106 [e1000]
May 3 16:42:10 dm02 kernel: [<c05a5324>] net_rx_action+0x92/0x175
May 3 16:42:10 dm02 kernel: [<c0427ed0>] __do_softirq+0x5a/0xbb
May 3 16:42:10 dm02 kernel: [<c0427f67>] do_softirq+0x36/0x3a
May 3 16:42:10 dm02 kernel: [<c0406340>] do_IRQ+0x6b/0x73
May 3 16:42:10 dm02 kernel: [<c040492e>] common_interrupt+0x1a/0x20
May 3 16:42:10 dm02 kernel: [<c0402b98>] default_idle+0x0/0x59
May 3 16:42:10 dm02 kernel: [<c0402bc9>] default_idle+0x31/0x59
May 3 16:42:10 dm02 kernel: [<c0402c90>] cpu_idle+0x9f/0xb9
May 3 16:42:10 dm02 kernel: [<c06da798>] start_kernel+0x380/0x387
May 3 16:42:10 dm02 kernel: =======================


Expected Results:
#


Additional info:
Bug _may_ not manifest in a vmware session according to one tester.
Comment 3 Steve Dickson 2010-09-13 13:11:50 EDT
Hey Dan,

This is pretty old... do more recent kernels have the same problem?
Comment 4 RHEL Product and Program Management 2014-03-07 07:49:01 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-02 09:18:56 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.