Bug 239394 - strange behaviour in Japanese locale
strange behaviour in Japanese locale
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xemacs-packages-extra (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-08 00:49 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 20070427-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 07:49:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot-XEmacs.png (34.23 KB, image/png)
2007-05-08 00:49 EDT, Jens Petersen
no flags Details
Don't try to load un-define in XEmacs >= 21.5 (in Japanese UTF-8 setups) (777 bytes, patch)
2007-05-08 12:19 EDT, Ville Skyttä
no flags Details | Diff
locale-start.el-ja.patch (3.90 KB, application/octet-stream)
2007-05-08 21:58 EDT, Jens Petersen
no flags Details
locale-start.el (11.92 KB, application/octet-stream)
2007-05-08 22:01 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2007-05-08 00:49:43 EDT
Description of problem:
When I run xemacs in Japanese, I see French text partly appearing in
initial help text.

Version-Release number of selected component (if applicable):
xemacs-21.5.27-8.fc7.x86_64
xemacs-common-21.5.27-8.fc7.x86_64
xemacs-packages-base-20061221-1.fc7.noarch
xemacs-packages-extra-20061221-1.fc7.noarch

How reproducible:
every time

Steps to Reproduce:
1. LANG=ja_JP.UTF-8 /usr/bin/xemacs -vanilla
2. LANG=ja_JP.UTF-8 /usr/bin/xemacs -help

Actual results:
1. see screenshot
2. outputs:

  Loading leim-list...

xemacs exiting.


Expected results:
1. No French in initial splash help text
2. help to appear in shell
Comment 1 Jens Petersen 2007-05-08 00:49:43 EDT
Created attachment 154311 [details]
Screenshot-XEmacs.png
Comment 2 Ville Skyttä 2007-05-08 12:17:45 EDT
(In reply to comment #0)
> 1. No French in initial splash help text

French is displayed... well, because the Japanese startup screen code actually
contains French :P.  I don't speak nor write either, will report upstream. 
Unless you happen to know Japanese well enough to provide the translation?
http://cvs.xemacs.org/viewcvs.cgi/XEmacs/packages/mule-packages/locale/start-files/ja/locale-start.el?rev=.&content-type=text/vnd.viewcvs-markup

> 2. help to appear in shell

After "xemacs exiting.", I see also 'Cannot open load file: "un-define"'; the
attached patch (for xemacs-packages-extra) appears to be one crude way of fixing
it for XEmacs >= 21.5, will send upstream too.
Comment 3 Ville Skyttä 2007-05-08 12:19:02 EDT
Created attachment 154344 [details]
Don't try to load un-define in XEmacs >= 21.5 (in Japanese UTF-8 setups)
Comment 4 Jens Petersen 2007-05-08 21:58:54 EDT
Created attachment 154374 [details]
locale-start.el-ja.patch

Here is a patch with Japanese translations.
I attached it as binary since I am not very sure what will happen to the
encodings
as plain text.	(Japanese is ISO2022-JP, French was already corrupted?)
Comment 5 Jens Petersen 2007-05-08 22:01:22 EDT
Created attachment 154375 [details]
locale-start.el

Note this is based on the current
"/usr/share/xemacs/mule-packages/etc/start-files/ja/locale-start.el"
in xemacs-packages-extra-20061221-1.fc7.
Comment 6 Jens Petersen 2007-05-08 22:06:28 EDT
(In reply to comment #5)
> Note this is based on the current [..]
> xemacs-packages-extra-20061221-1.fc7.

But since according to cvs this file hasn't changed in the last couple of years
that should be fine I guess. :)
Comment 7 Jens Petersen 2007-05-08 22:08:47 EDT
Comment on attachment 154375 [details]
locale-start.el

(Attachment 154375 [details] should be in iso2022-jp.)
Comment 8 Jens Petersen 2007-05-08 22:10:19 EDT
Oh, if upstream prefers utf-8 encoding I am happy to provide it too.
Comment 9 Ville Skyttä 2007-05-21 07:49:09 EDT
Fixed in 20070427-1 in Rawhide, and both changes committed upstream too.  Thanks!
Comment 10 Jens Petersen 2007-06-06 22:27:04 EDT
Maybe unrelated but when I ran xemacs in rawhide yesterday I noticed
some garbage/boxes in a couple of the entries on the menubar,
presumably fonts related - I guess until now the menu was not translated?

Do you want another bug for that?
Comment 11 Ville Skyttä 2007-06-07 10:16:42 EDT
Yes, please report all new bugs as such.

Anyway, I know that there are charset issues with the buffer tabs, but don't
remember encountering them in the menubar.
Comment 12 Jens Petersen 2007-06-13 01:37:27 EDT
Ok, no problem: I opened bug 243973 for the ja menubar issue.

Note You need to log in before you can comment on or make changes to this bug.