Bug 239397 - Jamendo plugin crashes Rhythmbox
Jamendo plugin crashes Rhythmbox
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-08 01:42 EDT by Luke Macken
Modified: 2016-09-19 22:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-25 12:09:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2007-05-08 01:42:02 EDT
Description of problem:
The jamendo plugin seems to cause an assertion.

Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/jamendo/jamendo/JamendoSource.py", line 338,
in change_idle_cb
    self.notify_status_changed()
NameError: free variable 'self' referenced before assignment in enclosing scope
rhythmbox: Modules/gcmodule.c:241: update_refs: Assertion `gc->gc.gc_refs ==
(-3)' failed.

Program received signal SIGABRT, Aborted.
[Switching to Thread -1209030400 (LWP 22476)]
0x0014c402 in __kernel_vsyscall ()
(gdb) bt
#0  0x0014c402 in __kernel_vsyscall ()
#1  0x03c7ff30 in *__GI_raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2  0x03c81781 in *__GI_abort () at abort.c:88
#3  0x03c7935e in *__GI___assert_fail (
    assertion=0x41ee4b "gc->gc.gc_refs == (-3)", 
    file=0x41edd4 "Modules/gcmodule.c", line=241, 
    function=0x41f2bf "update_refs") at assert.c:78
#4  0x003ed0f4 in collect (generation=1) at Modules/gcmodule.c:241
#5  0x003ed6cb in _PyObject_GC_Malloc (basicsize=16) at Modules/gcmodule.c:897
#6  0x003ed755 in _PyObject_GC_New (tp=0x445f80) at Modules/gcmodule.c:1342
#7  0x0036cdf8 in list_iter (seq=0xadeea4c) at Objects/listobject.c:2758
#8  0x0034863f in PyObject_GetIter (o=0xadeea4c) at Objects/abstract.c:2350
#9  0x003c2c64 in PyEval_EvalFrameEx (f=0xa5aba24, throwflag=0)
    at Python/ceval.c:2152
#10 0x003c5cdf in PyEval_EvalFrameEx (f=0x9baf9a4, throwflag=0)
    at Python/ceval.c:3652
#11 0x003c5cdf in PyEval_EvalFrameEx (f=0x9497884, throwflag=0)
    at Python/ceval.c:3652
#12 0x003c6b2f in PyEval_EvalCodeEx (co=0x91cff98, globals=0x91d2acc, 
    locals=0x0, args=0x91c9c68, argcount=3, kws=0x0, kwcount=0, defs=0x0, 
    defcount=0, closure=0x0) at Python/ceval.c:2833
#13 0x00365eaa in function_call (func=0x9430d4c, arg=0x91c9c5c, kw=0x0)
    at Objects/funcobject.c:517
#14 0x00346ee7 in PyObject_Call (func=0x57cc, arg=0x91c9c5c, kw=0x0)
    at Objects/abstract.c:1860
#15 0x0034e3e8 in instancemethod_call (func=0x942b964, arg=0x91c9c5c, kw=0x0)
    at Objects/classobject.c:2493
#16 0x00346ee7 in PyObject_Call (func=0x57cc, arg=0x91d172c, kw=0x0)
    at Objects/abstract.c:1860
#17 0x003becec in PyEval_CallObjectWithKeywords (func=0x942b964, 
    arg=0x91d172c, kw=0x0) at Python/ceval.c:3435
#18 0x014660ff in ?? ()
   from /usr/lib/python2.5/site-packages/_xmlplus/parsers/pyexpat.so
#19 0x01467df7 in ?? ()
   from /usr/lib/python2.5/site-packages/_xmlplus/parsers/pyexpat.so
#20 0x00a46ec2 in ?? () from /lib/libexpat.so.0
#21 0x00a47dbd in ?? () from /lib/libexpat.so.0
#22 0x00a414fb in XML_ParseBuffer () from /lib/libexpat.so.0
#23 0x00a4a1e2 in XML_Parse () from /lib/libexpat.so.0
#24 0x0146951c in ?? ()
   from /usr/lib/python2.5/site-packages/_xmlplus/parsers/pyexpat.so
#25 0x0037914d in PyCFunction_Call (func=0x942c1cc, arg=0x91d12cc, kw=0x0)
    at Objects/methodobject.c:108
#26 0x003c6024 in PyEval_EvalFrameEx (f=0x93c1b84, throwflag=0)
    at Python/ceval.c:3566
#27 0x003c6b2f in PyEval_EvalCodeEx (co=0x91cfcc8, globals=0x91d2acc, 
    locals=0x0, args=0x9bae94c, argcount=2, kws=0x9bae954, kwcount=0, 
    defs=0x942c9f8, defcount=1, closure=0x0) at Python/ceval.c:2833
#28 0x003c4d29 in PyEval_EvalFrameEx (f=0x9bae7f4, throwflag=0)
    at Python/ceval.c:3662
#29 0x003c6b2f in PyEval_EvalCodeEx (co=0x90a69b0, globals=0x9056e84, 
    locals=0x0, args=0x91cd848, argcount=6, kws=0x0, kwcount=0, defs=0x0, 
    defcount=0, closure=0x0) at Python/ceval.c:2833
#30 0x00365eaa in function_call (func=0x90d9ed4, arg=0x91cd83c, kw=0x0)
    at Objects/funcobject.c:517
#31 0x00346ee7 in PyObject_Call (func=0x57cc, arg=0x91cd83c, kw=0x0)
    at Objects/abstract.c:1860
#32 0x0034e3e8 in instancemethod_call (func=0x91b5b6c, arg=0x91cd83c, kw=0x0)
    at Objects/classobject.c:2493
#33 0x00346ee7 in PyObject_Call (func=0x57cc, arg=0x927302c, kw=0x0)
    at Objects/abstract.c:1860
#34 0x003becec in PyEval_CallObjectWithKeywords (func=0x91b5b6c, 
    arg=0x927302c, kw=0x0) at Python/ceval.c:3435
#35 0x003ddf8e in PyEval_CallFunction (obj=0x91b5b6c, 
    format=0xf19f60 "(OOOKO)") at Python/modsupport.c:556
#36 0x00f1367e in read_write_marshal (handle=0x5, result=GNOME_VFS_OK, 
    buffer=0xae60650, requested=65536, done=<value optimized out>, 
    notify=0xae5d630) at vfs-async-handle.c:302
#37 0x008e948b in dispatch_read_callback (notify_result=0xae272a0)
    at gnome-vfs-job.c:207
#38 0x008e9d66 in dispatch_job_callback (data=0xae272a0) at gnome-vfs-job.c:571
#39 0x00ddb8c1 in g_idle_dispatch (source=0xae26c58, callback=0x6, 
    user_data=0xae272a0) at gmain.c:3928
#40 0x00ddd622 in IA__g_main_context_dispatch (context=0x8c58368)
    at gmain.c:2045
#41 0x00de05ff in g_main_context_iterate (context=0x8c58368, block=1, 
    dispatch=1, self=0x8be9478) at gmain.c:2677
#42 0x00de09a9 in IA__g_main_loop_run (loop=0x8c0c0c8) at gmain.c:2881
#43 0x010d76a4 in IA__gtk_main () at gtkmain.c:1154
#44 0x080602d3 in main (argc=1, argv=0xbfdf0ae4) at main.c:384


Version-Release number of selected component (if applicable):
rhythmbox-0.10.0-6.fc7

How reproducible:
Always

Steps to Reproduce:
1. Open rhythmbox
2. Click "Jamendo"
Comment 1 Bastien Nocera 2007-08-20 10:13:18 EDT
Could you please test with the latest rhythmbox available if the problem still
occurs? Are you still using rawhide, or is this F7?
Comment 2 Luke Macken 2007-08-25 12:09:01 EDT
I am unable to reproduce this issue with the F7 rhythmbox.

Note You need to log in before you can comment on or make changes to this bug.