Bug 239406 - savecore will not use reserved space
Summary: savecore will not use reserved space
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: diskdumputils (Show other bugs)
(Show other bugs)
Version: 4.5
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Linda Wang
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-08 09:05 UTC by Bryn M. Reeves
Modified: 2018-10-19 23:35 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0717
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 15:59:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make diskdumputils use f_bfree when checking space (475 bytes, patch)
2007-05-08 09:09 UTC, Bryn M. Reeves
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0717 normal SHIPPED_LIVE diskdumputils bug fix update 2007-11-14 16:33:35 UTC

Description Bryn M. Reeves 2007-05-08 09:05:32 UTC
Description of problem:
In calculating the amount of disk space for a dump, savecore uses the f_bavail
field from statfs. Since this does not include reserved blocks a savecore can
fail despite there being sufficient space in the dump file system.

Version-Release number of selected component (if applicable):
1.3.25-1

How reproducible:
100%

Steps to Reproduce:
1. Configure a /var/crash filesystem that is just large enough to contain system RAM
2. Perform a crash, e.g. sysrq-c
3. Wait for reboot to save core
  
Actual results:
"no space for dump image."

Expected results:
Dump copies succesfuly

Additional info:

Comment 1 Bryn M. Reeves 2007-05-08 09:09:25 UTC
Created attachment 154321 [details]
patch to make diskdumputils use f_bfree when checking space

Comment 3 RHEL Product and Program Management 2007-05-08 20:19:51 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Akira Imamura 2007-06-28 20:46:03 UTC
I've already fixed the bug. The fix is included in diskdumputils-1.3.49. However
it is different from the proposed patch on comment #1.

Thanks,
Akira

Comment 5 Dave Anderson 2007-07-13 19:07:03 UTC
MODIFIED -- CVS Tag: diskdumputils-1_4_0-1

Comment 7 Dave Anderson 2007-07-17 18:08:53 UTC
The diskdumputils package has been re-spun -- CVS Tag: diskdumputils-1_4_1-1

Please post QA results here.  I will transfer the test results
to the errata's QA report, and then set this bugzilla to VERIFIED
via the errata interface.

Comment 8 Akira Imamura 2007-09-13 17:31:17 UTC
I've done testing. There's no regression and unfixed bug as for
this BZ. So could you please file the errata for me?

Thanks,
Akira


Comment 9 RHEL Product and Program Management 2007-09-13 19:50:30 UTC
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Comment 15 errata-xmlrpc 2007-11-15 15:59:13 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0717.html



Note You need to log in before you can comment on or make changes to this bug.