Bug 239417 - diskdump error message with IBM vscsi
diskdump error message with IBM vscsi
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-08 05:56 EDT by Bryn M. Reeves
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 16:25:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2007-05-08 05:56:55 EDT
+++ This bug was initially created as a clone of Bug #234334 +++

Description of problem:
Diskdump attempts to set the Write Cache Enable bit via a mode sense command. On
IBM vscsi devices this leads to messages like this being written to the console:

CPU frozen: #0#2#3#4#5#6#7#8#9#10#11
CPU#1 is executing diskdump.
start dumping to sdb1
<3>scsi_dump: command 1a failed with 0x2
<4>scsi_dump: MODE SENSE failed
check dump partition...
dumping memory..
27620/786432    868 ETA \

This is because the vscsi device does not support the caching mode page. In this
case the errors are harmless and can be ignored but they are logged as KERN_ERR
and KERN_WARNING.


Version-Release number of selected component (if applicable):
kernel-2.6.9-42.0.8.EL

How reproducible:
100%

Steps to Reproduce:
1. Configure diskdump to dump to a vscsi device
2. Trigger a crash dump, e.g. sysrq-c

  
Actual results:
Crash log contains:

CPU frozen: #0#2#3#4#5#6#7#8#9#10#11
CPU#1 is executing diskdump.
start dumping to sdb1
<3>scsi_dump: command 1a failed with 0x2
<4>scsi_dump: MODE SENSE failed
check dump partition...
dumping memory..
27620/786432    868 ETA \

Expected results:
Errors/Warnings are not logged.
Comment 1 Dave Anderson 2007-05-08 09:07:50 EDT
Huh?  diskdump doesn't exist in RHEL5.

Note You need to log in before you can comment on or make changes to this bug.