Bug 239434 - rhythmbox fails to notice/use fluendo mp3 plugin
rhythmbox fails to notice/use fluendo mp3 plugin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bastien Nocera
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-08 08:53 EDT by Alastair Neil
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.10.0-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-14 15:31:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of gst-inspect flump3dec (2.07 KB, text/plain)
2007-05-08 09:51 EDT, Alastair Neil
no flags Details
gst-debug-level=3 output from rhythmbox (extract) (29.83 KB, application/octet-stream)
2007-05-08 10:23 EDT, Alastair Neil
no flags Details

  None (edit)
Description Alastair Neil 2007-05-08 08:53:53 EDT
Description of problem:
rhythmbox will not play any mp3 files

Version-Release number of selected component (if applicable):
rhythmbox-0.10.0-6.fc7
ls -al ~/.gstreamer-0.10/plugins/
total 1048
drwx--x--x 2 ajn ajn    4096 2007-01-19 15:09 .
drwxr-xr-x 3 ajn 400    4096 2007-05-08 07:59 ..
-rwxr-xr-x 1 ajn ajn 1059876 2006-12-20 04:54 libgstflump3dec.so


How reproducible:
Always

Steps to Reproduce:
1. start rhythmbox
2. select mp3 file to play
3. 
  
Actual results:
file skipped

Expected results:
music

Additional info:
Totem plays the files fine.  This configuration worked under FC6.  I
re-downloaded the plugin and also tried installing directly in the
gstreamer-plugins directory to do avail.
Comment 1 Bastien Nocera 2007-05-08 09:25:37 EDT
What's the error message that you get in Rhythmbox? What's the output of
"gst-inspect-0.10 flump3dec"? Are you sure Totem isn't using the xine-lib
backend, and not the GStreamer one?
Comment 2 Alastair Neil 2007-05-08 09:51:13 EDT
Created attachment 154336 [details]
output of gst-inspect flump3dec
Comment 3 Alastair Neil 2007-05-08 10:23:26 EDT
Created attachment 154338 [details]
gst-debug-level=3 output from rhythmbox (extract)

This is what I was able to capture - it overwhelmed my gnome-terminal buffer.
Level 2 did not provide any relevant information.
Comment 4 Alastair Neil 2007-05-08 10:24:47 EDT
totem appears to be linked against the gstreamer backend as it produces a
prodigious amount of output when run with --gst-debug-level=3
Comment 5 Bastien Nocera 2007-05-08 10:53:05 EDT
You didn't answer as to what error message you see in Rhythmbox itself. I don't
see any errors in the log you provided. If you don't see any errors in the
application, could you attach the output of "rhythmbox -d" when reproducing the
problem?
Comment 6 Alastair Neil 2007-05-08 11:12:22 EDT
I need assistance in redirecting the error output 2>&1 on the command line does
nothing, and the output overwhelms my terminal buffer.

Here is a data point.  Gstreamer appears to be a red herring.  When trying to
pair down the debug output I disabled all plugins and voila it started to play.
 I then experimented and found that it is the visualisation plugin.  If it is
checked then  nothing will play.  If I uncheck it and restart the all is fine,
however once I check and attempt to play I need to uncheck and then restrat the
application to have it play again.

If you can tell me how to redirect the output I'd be glad to try and produce
some debug logs for you.
 

Note You need to log in before you can comment on or make changes to this bug.