Bug 239507 - usb device bounces on and off
usb device bounces on and off
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-08 20:09 EDT by Kevin Fenzi
Modified: 2007-11-30 23:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-30 23:23:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
usbmon output from bus 2t (23.27 KB, text/plain)
2007-06-19 15:50 EDT, Kevin Fenzi
no flags Details

  None (edit)
Description Kevin Fenzi 2007-05-08 20:09:40 EDT
Description of problem:

dell D820 laptop here with fingerprint reader, which is a usb device. 
In previous kernels it showed up and worked fine with the thinkfinger package. 
With the very latest bleeding edge kernel, the device sometimes is there, and
other times its gone. It also doesn't appear to work anytime. 

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3142.fc7.x86_64

How reproducible:
Boot into the above kernel, and use lsusb to look at usb devices. 

Steps to Reproduce:
1. boot
2. run lsusb
3. look for fingerprint device. Sometimes it's there, sometimes not. 

Additional info:

lsusb: 

Bus 002 Device 015: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader

(when the device shows up). 

dmesg is spewing the following: 

usb 2-1: USB disconnect, address 5
usb 2-1.1: USB disconnect, address 6
usb 2-1.2: USB disconnect, address 7
usb 2-1: new full speed USB device using uhci_hcd and address 8
usb 2-1: configuration #1 chosen from 1 choice
hub 2-1:1.0: USB hub found
hub 2-1:1.0: 3 ports detected
usb 2-1.1: new full speed USB device using uhci_hcd and address 9
usb 2-1.1: configuration #1 chosen from 1 choice
usb 2-1.2: new full speed USB device using uhci_hcd and address 10
usb 2-1.2: configuration #1 chosen from 1 choice
hub 2-1:1.0: hub_port_status failed (err = -71)
hub 2-1:1.0: cannot disable port 1 (err = -71)
hub 2-1:1.0: hub_port_status failed (err = -71)
hub 2-0:1.0: port 1 disabled by hub (EMI?), re-enabling...
usb 2-1: USB disconnect, address 8
usb 2-1.1: USB disconnect, address 9
usb 2-1.2: USB disconnect, address 10
usb 2-1: new full speed USB device using uhci_hcd and address 11
usb 2-1: configuration #1 chosen from 1 choice
hub 2-1:1.0: USB hub found
hub 2-1:1.0: 3 ports detected
usb 2-1.1: new full speed USB device using uhci_hcd and address 12
usb 2-1.1: configuration #1 chosen from 1 choice
usb 2-1.2: new full speed USB device using uhci_hcd and address 13
usb 2-1.2: configuration #1 chosen from 1 choice
hub 2-1:1.0: hub_port_status failed (err = -71)
hub 2-1:1.0: cannot disable port 1 (err = -71)
hub 2-1:1.0: hub_port_status failed (err = -71)
hub 2-1:1.0: hub_port_status failed (err = -71)
hub 2-0:1.0: port 1 disabled by hub (EMI?), re-enabling...
usb 2-1: USB disconnect, address 11
usb 2-1.1: USB disconnect, address 12
usb 2-1.2: USB disconnect, address 13
usb 2-1: new full speed USB device using uhci_hcd and address 14
usb 2-1: configuration #1 chosen from 1 choice
hub 2-1:1.0: USB hub found
hub 2-1:1.0: 3 ports detected
usb 2-1.1: new full speed USB device using uhci_hcd and address 15
usb 2-1.1: configuration #1 chosen from 1 choice
usb 2-1.2: new full speed USB device using uhci_hcd and address 16
usb 2-1.2: configuration #1 chosen from 1 choice

Happy to provide more info.
Comment 1 Kevin Fenzi 2007-05-08 20:15:52 EDT
BTW, looks like this might be filed as:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/102659
with ubuntu...

Comment 2 Pete Zaitcev 2007-05-31 12:50:38 EDT
Aww, man, I forgot to ask what was the last kernel that worked.
We should've saved it and re-tested now.
Comment 3 Kevin Fenzi 2007-05-31 12:58:23 EDT
Yeah, I meant to go back and figure out when it broke, but I didn't. ;( 

I can try and go back and see what kernel broke it. 
Not going to be easy though. ;( 

Comment 4 Kevin Fenzi 2007-06-19 15:19:46 EDT
Sorry for the delay here. Now I have waited to the point where it's gonna be
hard to find the older kernels to test. 

This still occurs with the latest f8 update kernel: 
kernel-2.6.21-1.3228.fc8.x86_64

Is there any further info I can gather that would help tracking this down? 
Or is there a specific kernel you would like me to test with?
Comment 5 Pete Zaitcev 2007-06-19 15:40:51 EDT
We can do two things
1. Rebuild the RPM carefuly with CONFIG_USB_SUSPEND disabled, but without
   changing anything else, see if that helps, and
2. Get usbmon trace with which I could go to linux-usb-devel.
   This needs not rebuilds. There's a howto here:
   /usr/share/doc/kernel-doc-2.6.21/Documentation/usb/usbmon.txt
Comment 6 Kevin Fenzi 2007-06-19 15:49:19 EDT
ok, #2 sounds easy... 

I am attaching the usbmon trace. I started it and did some lsusb's and watched
the device appear and disappear a few times. 

When present: 

Bus 005 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 034: ID 0b97:7762 O2 Micro, Inc. Oz776 SmartCard Reader
Bus 002 Device 033: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
Bus 002 Device 032: ID 0b97:7761 O2 Micro, Inc. 
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 012: ID 413c:8103 Dell Computer Corp. Wireless 350 Bluetooth
Bus 001 Device 011: ID 413c:8128 Dell Computer Corp. 
Bus 001 Device 010: ID 413c:a005 Dell Computer Corp. 
Bus 001 Device 001: ID 0000:0000 

from dmesg: 

hub 2-1:1.0: hub_port_status failed (err = -71)
hub 2-1:1.0: cannot disable port 1 (err = -71)
hub 2-1:1.0: hub_port_status failed (err = -71)
hub 2-0:1.0: port 1 disabled by hub (EMI?), re-enabling...
usb 2-1: USB disconnect, address 29
usb 2-1.1: USB disconnect, address 30
usb 2-1.2: USB disconnect, address 31
usb 2-1: new full speed USB device using uhci_hcd and address 32
usb 2-1: configuration #1 chosen from 1 choice
hub 2-1:1.0: USB hub found
hub 2-1:1.0: 3 ports detected
usb 2-1.1: new full speed USB device using uhci_hcd and address 33
usb 2-1.1: configuration #1 chosen from 1 choice
usb 2-1.2: new full speed USB device using uhci_hcd and address 34
usb 2-1.2: configuration #1 chosen from 1 choice
Comment 7 Kevin Fenzi 2007-06-19 15:50:33 EDT
Created attachment 157411 [details]
usbmon output from bus 2t

Here's the usbmon trace
Comment 8 Chuck Ebbert 2007-06-19 15:50:48 EDT
(In reply to comment #5)
> We can do two things
> 1. Rebuild the RPM carefuly with CONFIG_USB_SUSPEND disabled, but without
>    changing anything else, see if that helps, and

I think we need this anyway. There are devices that require quirks
to work with it enabled, and we'll be forever chasing those if we
leave it enabled.
Comment 9 Pete Zaitcev 2007-06-20 17:32:00 EDT
Mental note: see also 243798 (don't dup just yet, please!)
Comment 10 Kevin Fenzi 2007-11-30 23:23:52 EST
Sorry to leave this one around... works just fine these days. 
I am going to go ahead and close this bug... 

Note You need to log in before you can comment on or make changes to this bug.