Bug 239513 - xfce4-mixer should be configured to use ALSA
xfce4-mixer should be configured to use ALSA
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-mixer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-08 21:23 EDT by Jeff Layton
Modified: 2014-06-18 03:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.4.1-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 12:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
specfile patch -- build the program for the ALSA backend (454 bytes, patch)
2007-05-08 21:23 EDT, Jeff Layton
no flags Details | Diff

  None (edit)
Description Jeff Layton 2007-05-08 21:23:03 EDT
xfce4-mixer seems to use the standard "%configure" in the specfile. This makes
the configure script autodetect how to build the program, and it seems to pick
OSS. Given that fc6 and above come ALSA-enabled, this should probably be changed.

This trivial patch seemed to work on a brief build and test...
Comment 1 Jeff Layton 2007-05-08 21:23:03 EDT
Created attachment 154370 [details]
specfile patch -- build the program for the ALSA backend
Comment 2 Kevin Fenzi 2007-05-08 22:27:33 EDT
Bummer. I thought I fixed this a while back. ;( 

Looks like it might also need BuildRequires: alsa-lib-devel and some other tweaks. 
Will do some testing here. 

Thanks for the bug report. 
Comment 3 Fedora Update System 2007-06-07 12:00:42 EDT
xfce4-mixer-4.4.1-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.