Bug 239529 - unable to access resume device label swap
Summary: unable to access resume device label swap
Status: CLOSED DUPLICATE of bug 544478
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Brian Lane
QA Contact: Kevin Baker
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-09 07:02 UTC by nickcheng
Modified: 2014-12-01 23:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:49:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nickcheng 2007-05-09 07:02:02 UTC
I installed RHEL5 several days ago and it works good.
Then I made kernel-2.6.20 and kernel-2.6.21.1 on my system.
When I booted up with kernel-2.6.20 and kernel-2.6.21.1, I got the message as below:

********************************************************************
********************************************************************
Unable to access resume device (LABEL=SWAP-sda2)
Mount: could not find filesystem "/dev/root"
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting proc: No such file or directory
setuproot: Error mounting /sys: No such file or directory
switchroot: Mount failed: No such file or directory
Kernel Panic - not syncing: Attempted to kill init! 
*********************************************************************
*********************************************************************
My /etc/grub.conf is:
++++++++++++++++++++++++++++++++++++++++++++++++++
++++++++++++++++++++++++++++++++++++++++++++++++++
default=2
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux Server (2.6.18-8.el5)
root (hd0,0)
kernel /boot/vmlinuz-2.6.18-8.el5 ro root=/dev/sda1 rhgb quiet
initrd /boot/initrd-2.6.18-8.el5.img
title Red Hat Enterprise Linux Server (2.6.20)custom
root (hd0,0)
kernel /boot/bzImage-2.6.20.custom ro root=/dev/sda1 rhgb quiet
initrd /boot/initrd-2.6.20.custom.img
title Red Hat Enterprise Linux Server (2.6.21.1)custom
root (hd0,0)
kernel /boot/bzImage-2.6.21.1.custom ro root=/dev/sda1 rhgb quiet
initrd /boot/initrd-2.6.21.1.custom.img
++++++++++++++++++++++++++++++++++++++++++++++++++++++
++++++++++++++++++++++++++++++++++++++++++++++++++++++

My /etc/fstab is :
**********************************************************************
**********************************************************************
LABEL=/ / ext3 defaults 1 1
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/sda3 swap swap defaults 0 0
***********************************************************************
***********************************************************************

I make the kernel several times and never suffer this condition.

Comment 1 nickcheng 2007-05-14 02:52:33 UTC
I found if I install the system on the SATA drive, it will show the error
message and panic the kernel.
But if I change to install on IDE drive, it works good.
Would you please check it out?
Thanks,

Comment 2 Alexander Todorov 2008-11-07 11:42:16 UTC
I see this with F10 Preview: 

 Reading all physical volumes.  This may take a while...
  Volume group "VolGroup00" not found
Unable to access resume device (/dev/VolGroup00/LogVol01)
mount: error mounting /dev/root on /sysroot as ext3: No such file or directory
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Mount failed for selinuxfs on /selinux:  No such file or directory
switchroot: mount failed: No such file or directory
sd 2:2:0:0: [sda] Asking for cache data failed
sd 2:2:0:0: [sda] Assuming drive cache: write through
sd 2:2:0:0: [sda] Asking for cache data failed
sd 2:2:0:0: [sda] Assuming drive cache: write through


is it related ?

Comment 3 Nick Cheng 2008-11-10 03:17:40 UTC
Yes, I guess.

Comment 4 nickcheng 2009-04-13 01:56:34 UTC
(In reply to comment #2)
> I see this with F10 Preview: 
> 
>  Reading all physical volumes.  This may take a while...
>   Volume group "VolGroup00" not found
> Unable to access resume device (/dev/VolGroup00/LogVol01)
> mount: error mounting /dev/root on /sysroot as ext3: No such file or directory
> setuproot: moving /dev failed: No such file or directory
> setuproot: error mounting /proc: No such file or directory
> setuproot: error mounting /sys: No such file or directory
> Mount failed for selinuxfs on /selinux:  No such file or directory
> switchroot: mount failed: No such file or directory
> sd 2:2:0:0: [sda] Asking for cache data failed
> sd 2:2:0:0: [sda] Assuming drive cache: write through
> sd 2:2:0:0: [sda] Asking for cache data failed
> sd 2:2:0:0: [sda] Assuming drive cache: write through
> 
> 
> is it related ?  
Hi Alex,
So far, I still gt no clue with it.
Could you please throw me some light on it?
Thanks,

Comment 5 Antonio 2009-06-25 10:00:43 UTC
I have this problem also with F11

Comment 7 Brian Lane 2012-05-15 18:49:41 UTC
Sounds like a dupe of bug 544478.

*** This bug has been marked as a duplicate of bug 544478 ***


Note You need to log in before you can comment on or make changes to this bug.