Bug 239580 - ntp isn't compiled with crypto and readline support
Summary: ntp isn't compiled with crypto and readline support
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ntp   
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Miroslav Lichvar
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: EasyFix, Regression
Depends On: 239576
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-09 16:30 UTC by Miroslav Lichvar
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2007-0381
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 18:00:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0381 normal SHIPPED_LIVE ntp bug fix update 2007-10-30 14:42:54 UTC

Description Miroslav Lichvar 2007-05-09 16:30:10 UTC
Description of problem:
ntp on 64bit architectures isn't compiled with crypto support. %configure macro
should have --with-openssl-libdir=%{_libdir}.

Also, ntpq and ntpdc utilities are compiled without readline support, in
buildrequires should be ncurses-devel.

Steps to Reproduce:
1. ldd /usr/sbin/ntpd /usr/sbin/ntpq | grep 'crypto\|readline'
  
Actual results:

Expected results:
libcrypto.so.6
libreadline.so.5

Comment 1 RHEL Product and Program Management 2007-05-09 16:43:48 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 RHEL Product and Program Management 2007-05-09 16:46:12 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 7 errata-xmlrpc 2007-11-07 18:00:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0381.html



Note You need to log in before you can comment on or make changes to this bug.