Bug 239617 - rtc_cmos: probe of 00:06 failed with error -16
rtc_cmos: probe of 00:06 failed with error -16
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-09 18:01 EDT by Orion Poplawski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 15:34:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-05-09 18:01:28 EDT
Description of problem:

Logwatch reports:

--------------------- Kernel Begin ------------------------ 

 WARNING:  Kernel Errors Present
    rtc_cmos: probe of 00:06 failed with error -16 ...:  1 Time(s)
 
 ---------------------- Kernel End ------------------------- 

dmesg contains:

rtc_cmos 00:06: rtc core: registered rtc_cmos as rtc0
rtc_cmos: probe of 00:06 failed with error -16

Either:

- it's a kernel issue that needs fixing
- a kernel message that really shouldn't be reported
- something logwatch needs to ignore.

This is on an old Dell Inspiron 4150.  Let me know if you need any more hardware
details.

Version-Release number of selected component (if applicable):
2.6.21-1.3116.fc7
Comment 1 Orion Poplawski 2007-05-09 18:08:10 EDT
Looks like some upstream work is being done: http://lkml.org/lkml/2007/3/7/78

Looks like a conflict between the old RTC driver (CONFIG_RTC=y) and the new
rtc_cmos module (CONFIG_RTC_DRV_CMOS=m).
Comment 2 Chuck Ebbert 2007-05-09 18:35:40 EDT
We should be using one or the other. (Looks like the patch was never submitted.)
Comment 3 Dave Jones 2007-05-15 14:50:36 EDT
This should be fixed in the latest builds. (3148 and above)
Comment 4 Orion Poplawski 2007-05-25 17:11:06 EDT
The rtc_cmos messages are gone.  I've now got:

drivers/rtc/hctosys.c: unable to open rtc device (rtc0)

which I believe would have been provided by rtc_cmos.  Not a big deal I think,
but I thought I'd mention it.
Comment 5 Dave Jones 2007-09-24 15:34:41 EDT
There are two other bugs open for that problem (230935 and 274261)
Not entirely sure whats up with that yet.

Note You need to log in before you can comment on or make changes to this bug.