Bug 239626 - F7T4 RAID1/LVM Install Issues - Empty /boot, /, /var
Summary: F7T4 RAID1/LVM Install Issues - Empty /boot, /, /var
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-10 01:12 UTC by Brian Hanks
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 20:38:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Disk Layout Info (11.61 KB, text/plain)
2007-05-10 01:12 UTC, Brian Hanks
no flags Details

Description Brian Hanks 2007-05-10 01:12:04 UTC
Description of problem:
Installing F7T4 over an FC6 install that utilizes software RAID1 and LVM seems
to work flawlessly, but after clicking Reboot button system ends up at grub
prompt.  Inspection shows empty /boot (ext3), /var (RAID1), and / (RAID1)
partitions.  


Version-Release number of selected component (if applicable):


How reproducible:
Seems to be consistent; same result from two attempts.

Steps to Reproduce:
1. Install FC6 Re-Spin to match attached disk, RAID, and LVM layout.  
2. Install F7T4 over the top of it using same layout.  Choose to reformat all
partitions except non-OS data partitions, /opt, and /home.  Install should
complete normally.  
3. Click Reboot button.
  
Actual results:
Install seems to finish without issue.  Reboot results in the grub prompt. 
Several key partitions are empty (/, /boot, /var).  


Expected results:
Reboot after install should result in the system booting and the First Time boot
interface.

Additional info:
MB:  Asus A7V600
CPU:  AMD Athlon XP3000+
RAM:  1.5 GB DDR
HD1:  Samsung SP1213C 120GB SATA (/dev/sda)
HD2:  Samsung SP1213C 120GB SATA (/dev/sdb)
HD3:  WDC 80GB IDE (/dev/hda)
CD1:  Plextor PX-712A (/dev/hdc)
CD2:  Lite-On LTR-32123S (/dev/hdd)
Video:  Gainward GeForce2 Ti AGP

Comment 1 Brian Hanks 2007-05-10 01:12:04 UTC
Created attachment 154442 [details]
Disk Layout Info

Comment 2 Jeremy Katz 2007-05-14 19:05:42 UTC
Can you grab /var/log/anaconda* and attach them here?

Comment 3 Brian Hanks 2007-05-15 11:14:22 UTC
(In reply to comment #2)
> Can you grab /var/log/anaconda* and attach them here?

Interesting is that I don't have any files that match /var/log/anaconda*.  I
performed the install two more times last night and the behaviour was somewhat
different that what I saw originally.  This time, the install never happens.  It
gets to the point where the install should start (post partitioning and PKG
selection) and it pops up this error:


Error mounting device Volume02/lv_images as /prod/images:  No such file or
directory.
This most likely means this partition has not been formatted.
Press OK to reboot your system.


This directory was not formatted and should not have been.  I contains existing
data files that were supposed to be preserved by the install.  

I'm guessing that this is the root cause of the behavior that I originally
described.  

Comment 4 Srihari Vijayaraghavan 2007-06-09 00:17:14 UTC
I think I've somewhat similar test case:
  Using Fedora 7 KDE Live CD i386, when I choose to install /boot partition plus
LVM based /, /usr, /var, /home etc., the installer is unhappy with / LV with
lesser than ~4GB, an indication (to me) installer is unable to understand that
besides / LV there are other LVs & thus / LV could be a smaller LV.

So I had to install it using only / LV (~4GB). I've the system running fine now.
I'm happy to provide any other info needed. Also, this installation problem is
rather easy to reproduce.


Comment 5 Chris Lumens 2007-08-13 17:07:39 UTC
This could be due to messing up the order for mounting partition requests.  I
did some work in this area recently.  Can you please try F8 test 1 and see if
this is fixed for you?

Comment 6 Brian Hanks 2007-09-18 20:36:31 UTC
This appears to be fixed, so I am going to close.


Note You need to log in before you can comment on or make changes to this bug.