Product: Fedora
Classification: Fedora
Component: autorun (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2007-05-09 22:02 EDT by Leslie Satenstein
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-26 15:48:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Leslie Satenstein 2007-05-09 22:02:20 EDT
Description of problem:

After logging into fc7, insert USB cable from 250 gig hard disk. Disk does not

Sandisk flash drive is detected.

Automount works with fc6

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Leslie Satenstein 2007-05-13 20:57:11 EDT
This problem is intermittent. It occasionally fails to mount the hard drive. Was
checking Selinux logs in case it was a selinux problem. (Which it could be). 
While reviewing logs, inserted usb, and mount took place.  Disk formatted using
gparted with defaults (dos label, ext3, 232gig after formatting) 
Comment 2 Leslie Satenstein 2007-05-13 21:17:00 EDT
Uncollaborated situation.  I cleared the Selinux logs, (deleted all entries, and
since then, automount is functioning. I did not reboot to determine if 
a) if the device is left connectec via the usb, it it will show in an automount,
b) the automount is working if Selinux is cleared.

At this point, I am assuming that with the logs acknowledged and cleared, that
this issue may be closed, I will get back to you in the next 24 hrs. (21 hrs May
12 + 24hrs) 
Comment 3 Leslie Satenstein 2007-05-13 22:20:13 EDT
Here is the follow up information.

If the drive was plugged in at boot time, and the user logs in, the automount
will not take place. 

I tried this with leaving the drive connected, and logging in and waiting for s
usb scan. That is when I expected the drive to be recognized.
Then I unplugged the drive, waited a minute and replugged it. Still not recognized.

I also logged out and tried to get the drive recognized after relogging to the
system. Sorry, drive is not recognized.

I then rebooted, with the drive not plugged to the USB port.

The only way I found that FC7 appears to recognize the automount is if the drive
was not plugged in during the boot process. 

Will add to these comments if the same situation exists with FC6. I did not
experience automount problems with FC6.
Comment 4 Leslie Satenstein 2007-05-13 22:53:16 EDT
Last entry... 

If the USB drive is unplugged for more than two minutes, and then replugged, the
automount recognizes it and the drive icon appears on the desktop.

You decide if this is a normal operation, or did I find some exceptional /
undocumented conditions such as needing to wait more than two minutes after
unplugging the drive (left in at system boot) for automount logic to reset itself.

If what I report is normal, close out this reported bug. 

Note You need to log in before you can comment on or make changes to this bug.