Bug 239662 - HTS: HWCERT: U320 SCSI RAID0/1 storage test fails
HTS: HWCERT: U320 SCSI RAID0/1 storage test fails
Status: CLOSED WORKSFORME
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-10 08:25 EDT by Ram
Modified: 2008-07-16 17:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 09:30:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ram 2007-05-10 08:25:09 EDT
Description of problem:
The storage certification for U320 SCSI RAID0/1 card fails for 32 bit and 64 
bit OS. 

Version-Release number of selected component (if applicable):
hts-5.0-32.noarch

How reproducible:
Always on U320 card with RAID 0 or 1 configured and OS installed on it.

Steps to Reproduce:
1. Install RHEL5GA Server on PE2650 disks connected to U320 card.
2. Install hts suite hts-5.0-32.noarch and any dependent rpms.
3. Run "hts plan"; "hts print" and "hts certify -t storage".
4. The certification never goes through; throwing errors like "/usr/bin/rhts-
report-result: line 38: test-result.xml: Read-only file system".
5. Then the root file system is mounted as read only. The system becomes 
unusable.
  
Actual results:
"hts print" shows:
[root@localhost ~]# hts print
warning: Non-ASCII character '\xff' in 
file /usr/lib/python2.4/encodings/aliases.py on line 1, but no encoding 
declared; see http://www.python.org/peps/pep-0263.html for details
'import site' failed; use -v for traceback
Traceback (most recent call last):
  File "/usr/bin/hts", line 20, in ?
    from hts.hardwaretest import HardwareTestHarness
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 29, in ?
    from hts.certificationtest import Certification, Test, Run  
  File "/usr/lib/python2.4/site-packages/hts/certificationtest.py", line 19, 
in ?
    from xml.dom.minidom import getDOMImplementation, parse
  File "/usr/lib/python2.4/site-packages/_xmlplus/dom/__init__.py", line 236, 
in ?
    import MessageSource
  File "/usr/lib/python2.4/site-packages/_xmlplus/dom/MessageSource.py", line 
21, in ?
    _ = get_translator("dom")
  File "/usr/lib/python2.4/site-packages/_xmlplus/FtCore.py", line 54, in 
get_translator
    f = gettext.translation('4Suite', locale_dir).gettext
  File "/usr/lib/python2.4/gettext.py", line 465, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib/python2.4/gettext.py", line 177, in __init__
    self._parse(fp)
  File "/usr/lib/python2.4/gettext.py", line 324, in _parse
    tmsg = unicode(tmsg, self._charset)
LookupError: no codec search functions registered: can't find encoding


Expected results:
The storage certification should pass through

Additional info:
kernel version 2.6.18-8.el5PAE
BIOS version A21
SCSI RAID 0/1 BIOS: v4.30.4S5
raid0 configured with three 36 GB SCSI disks connected to the card and OS 
installed on them
This happens on PE2850 also with the same U320 card
Adaptec Aic790X U320 SCSI Host Bus Adapter driver version: 3.0
Comment 1 Greg Nichols 2007-06-19 11:51:12 EDT
Please attach /var/hts/results.xml 

Also, are you saying that the test changes mounted filesystems?

Note that HTS needs to write to /var/log/hts and /var/hts - are these
filesystems writable?

Thanks!

Comment 2 Ram 2007-08-24 06:39:30 EDT
It will not have the /var/hts/results.xml file modified because the / itself 
has become read-only. If I don't run the test, the system works fine. That 
means it is the test which is changing the mounted filesystem.

Even a simple "ls" is not working and /var/log/hts and /var/hts are not 
writable.
Comment 3 YangKun 2007-10-08 05:55:15 EDT
Hi Ram,

The newest HTS is hts-5.0-48 , could you please try to use this version to
re-test and see if this issue still exist ?

Thanks very much!
-YK

Note You need to log in before you can comment on or make changes to this bug.