Bug 23967 - mgetty does not work with serial consoles
mgetty does not work with serial consoles
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mgetty (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-13 17:39 EST by Dr. Tilmann Bubeck
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-13 15:27:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dr. Tilmann Bubeck 2001-01-13 17:39:36 EST
If you use a serial console as the only screen for your linux machine (see
/usr/src/linux/Documentation/serial-console.txt) then mgetty will not work
for this configuration. The machine will boot sucessfully and display all
boot messages onto the terminal but will not print anything like "login..."
onto the terminal.

I debugged mgetty and found out, that the INPUT is transferred to mgetty
but no OUTPUT is displayed on the terminal.

If I use agetty (which should be in util-linux but is not -> this is in
bugzilla, too) instead of mgetty, then everything works fine and I could
log into the machine using my terminal.

It seems, that either mgetty is not able to work with serial consoles or it
is broken in RH 7.
Comment 1 Pekka Savola 2001-01-14 08:27:12 EST
What does your inittab like look like?  Serial console should be well off with a simpler
getty too.

We're using the following (from getty_ps package, though) and it works fine:

S0:2345:respawn:/sbin/getty ttyS0 DT38400 vt102
Comment 2 Dr. Tilmann Bubeck 2001-01-15 15:53:53 EST
You are right. getty_ps works fine. BUT mgetty did not work:

S0:2345:respawn:/sbin/mgetty -p "TILLBUEBCK" -r -x 9 -s 9600 ttyS0

However, also agetty and getty_ps worked fine:

S0:2345:respawn:/sbin/agetty ttyS0 9600 ansi
-or-
S0:2345:respawn:/sbin/getty ttyS0 DT9600 ansi

I recompiled mgetty from scratch and did not made a success. So I assume, that
mgetty itself is broken and that this is no RHAT bug.

+-------+--------------------------------------------------------------+
|       | dr. tilmann bubeck               think@work it consulting    |
|       |                                  professional services       |
| think | cell.: +49 172 8842972           widmaierstrasse 58          |
| @work | fax  : +49 711 7227734           70567 stuttgart             |
|       | email: bubeck@think-at-work.de   http://www.think-at-work.de |
+-------+ -------------------------------------------------------------+
Comment 3 Helge Deller 2001-06-13 09:54:22 EDT
could you please test the newest version from
ftp://wallace.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS
again and report your results ?
If you don't want to upgrade your system you may also just recompile the 
src.rpm and try that.
Comment 4 Dr. Tilmann Bubeck 2001-06-13 15:27:26 EDT
I would try the new package, but I could not log into the server you've given:

[root@localhost ~bubeck/download]# ftp wallace.redhat.com
Connected to wallace.redhat.com.
421 Service not available, remote server has closed connection
ftp> bye
[root@localhost ~bubeck/download]#

Should I try mgetty-1.1.26-3.src.rpm from a rawhide mirror instead? Why 
couldn't I use rawhide directly? It's asking for a password. Where can I get 
one?


Comment 5 Dr. Tilmann Bubeck 2001-06-14 15:33:52 EDT
I tried the unchanged mgetty-1.1.25-2 of RH 7.1 and also mgetty-1.1.26-3 of 
rawhide, and....
 
both worked!
 
There was no problem at all, everything worked fine. Thanks for any help!
 
Till

Note You need to log in before you can comment on or make changes to this bug.