Bug 239687 - wanted: some way to get the console terminal
wanted: some way to get the console terminal
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-10 11:19 EDT by Gerd Hoffmann
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 04:44:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerd Hoffmann 2007-05-10 11:19:33 EDT
Description of problem:

wishlist: new command for virsh to get the console device, like "virsh
vncdisplay dom" but for the text console.  suggested name: console-tty
Comment 1 Daniel Veillard 2007-06-29 11:50:44 EDT
Well you can get the information from 'dumpxml' output, it's just a matter
of filtering, virsh could do it, but is that worth adding a new command ?

Daniel
Comment 2 Gerd Hoffmann 2007-07-02 11:54:09 EDT
When it is worth a separate command for the vnc graphical console, the same
should apply to the text console, no?

It would provide easy access to the tty for scripting purposes, for example to
attach the console to a screen window (screen as in "terminal multiplexer app").

Comment 3 Daniel Berrange 2007-07-02 11:58:04 EDT
As Gerd says in comment #2, we already have a vncdisplay command - principally
because parsing XML from a shell script is a horrific task. Same motivation
applies for getting the console path - both are reasonably commonly needed bits
of info about a VM for shell scripting purposes.
Comment 4 Richard W.M. Jones 2007-07-02 12:07:07 EDT
It's be nice if Fedora bundled the xpath command
(http://www.xml.com/lpt/a/954), which makes shell
scripting this all quite easy.
Comment 5 Daniel Veillard 2007-07-26 04:44:54 EDT
Okay, I added a ttyconsole command which does this, it's upstream
and will be in the next release (probably 0.3.2),

  thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.