Bug 239698 - xcdroast fails to access cdrecord
xcdroast fails to access cdrecord
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xcdroast (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 241035 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-10 11:57 EDT by John McBride
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.98a15-14.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 23:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John McBride 2007-05-10 11:57:29 EDT
Description of problem:

xcdroast fails to access cdrecord

Version-Release number of selected component (if applicable):

xcdroast-0.98a15-13.i386.rpm

How reproducible:

# xcdroast 

or 

$ xcdroast


Steps to Reproduce:
1. Install xcdroast
2. Run it at the command line
3.
  
Actual results:

$ xcdroast

** (xcdroast:9473): WARNING **: Failed to access cdrecord. Please check the
permissions and ownership of /usr/bin/cdrecord

(same result as root user)

Expected results:

xcdroast GUI

Additional info:

$ ls -l /usr/bin/cdrecord 
lrwxrwxrwx 1 root root 5 2007-05-03 10:21 /usr/bin/cdrecord -> wodim

$ ls -l /usr/bin/wodim 
-rwxr-xr-x 1 root root 389292 2007-04-23 03:01 /usr/bin/wodim
Comment 1 Mamoru TASAKA 2007-06-04 00:31:27 EDT
Well, it seems that at least some code modification
releated to check_binaries() in src/init.c is required.

Especially in src/init.c and src/io.c, xcdroast tries
to check the existence of the binaries in what was in
cdrecord by calling the binary with -version for example,
and xcdroast expects that the output message (i.e.
cdrecord -version, now wodim -version) follows the format what
cdrecord returned.
Comment 2 Mamoru TASAKA 2007-06-04 00:32:08 EDT
*** Bug 241035 has been marked as a duplicate of this bug. ***
Comment 3 geoff 2007-06-15 09:34:41 EDT
you can get xcdroast working in fedora 7 by installing cdrecord from an older fc
release.  here's what I did:

$ sudo mv /usr/bin/cdrecord /usr/bin/cdrecord.f7
$ sudo mv /usr/bin/dvdrecord /usr/bin/dvdrecord.f7
$ sudo mv /usr/bin/devdump /usr/bin/devdump.f7
$ sudo rpm -ivh --force cdrecord-2.01.01.0.a03-3.i386.rpm

after that, you'll want to patch xcdroast in the gnome toolbar to start xcdroast
with the -n option, since mkisofs has a conflict as well.

--- /usr/share/applications/~xcdroast.desktop   2007-06-15 09:17:14.000000000 -0400
+++ /usr/share/applications/xcdroast.desktop    2007-06-15 09:17:28.000000000 -0400
@@ -2,7 +2,7 @@
 Encoding=UTF-8
 Name=CD Writer
 Type=Application
-Exec=/usr/bin/xcdroast
+Exec=/usr/bin/xcdroast -n
 Comment=CD creation tool
 Icon=/usr/lib/xcdroast-0.98/icons/xcdricon.png
 X-Desktop-File-Install-Version=0.12

after _that_ launching xcdroast from the applications seems to work.

HTH
Comment 4 Mamoru TASAKA 2007-06-15 09:42:55 EDT
(In reply to comment #3)
> you can get xcdroast working in fedora 7 by 
> installing cdrecord from an older fc
> release.  

Of course it may work, however this must not be our solution..
Comment 5 Fedora Update System 2007-06-21 16:02:10 EDT
xcdroast-0.98a15-14.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-06-26 23:54:25 EDT
xcdroast-0.98a15-14.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.