Bug 239707 - avc:denied /usr/sbin/in.tftpd (tftpd_t)
Summary: avc:denied /usr/sbin/in.tftpd (tftpd_t)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tftp   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Nagy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: SELinux
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-10 17:14 UTC by ericm24x7
Modified: 2016-07-26 23:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 10:53:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
selinux troubleshooter output log (2.30 KB, text/plain)
2007-05-10 17:14 UTC, ericm24x7
no flags Details

Description ericm24x7 2007-05-10 17:14:57 UTC
Description of problem:
selinux denying access for tftpd.

here is the raw audit messages:

avc: denied { search } for comm="in.tftpd" dev=sda6 egid=0 euid=0
exe="/usr/sbin/in.tftpd" exit=-13 fsgid=0 fsuid=0 gid=0 items=0 name="/"
pid=3873 scontext=user_u:system_r:tftpd_t:s0 sgid=0

Version-Release number of selected component (if applicable):
tftp-server-0.42-4
selinux-policy-2.6.1-1.fc7
filesystem-2.4.6-1.fc7

How reproducible:
persistent

Steps to Reproduce:
1. yum install tftp tftp-server
2. vi /etc/xinetd.d/tftp
   # edit/change the following variables:
    disable = no
    server_args = -s /a
3. execute from remote client:
   # assumed localhost = 192.168.3.103 and /a has "pxelinux.0" file
   tftp 192.168.3.103 -c get pxelinux.0

Actual results:
From client getting "Transfer timed out."
Attached file is the output of selinux troubleshooter

Comment 1 ericm24x7 2007-05-10 17:14:57 UTC
Created attachment 154486 [details]
selinux troubleshooter output log

Comment 2 Martin Nagy 2008-03-03 10:53:29 UTC
This is not a bug and selinux is supposed to deny access. Hence closing as NOTABUG.
If you want to fix this, execute:
chcon --reference=/tftpboot /a


Note You need to log in before you can comment on or make changes to this bug.