Bug 239718 - GFS2: glock not being released
GFS2: glock not being released
Status: CLOSED DUPLICATE of bug 239777
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Whitehouse
Dean Jansa
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-10 14:48 EDT by David Teigland
Modified: 2009-05-27 23:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-11 08:56:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2007-05-10 14:48:43 EDT
Description of problem:

<refried> this was my first try
<refried> mounted and chmod'd on morph-01 just fine.  
<refried> mounted and chmod hung on morph-02
<refried> I also don't know if all the patches that swhiteho intended are in -18

morph-01:

Glock 0xf10366bc (2, 22)
  gl_flags = 5 (unlocked) 
  gl_ref = 2
  gl_state = 1
  gl_owner = pid 6488 (bash)
  gl_ip = 4174432736
  req_gh = no
  req_bh = no
  lvb_count = 0
  object = yes
  le = no
  reclaim = no
  aspace = 0xf104569c nrpages = 1
  ail = 0
  Inode:
    num = 1/22
    type = 4
    i_flags = 

Resource e6714ec0 Name (len=24) "       2              16"  
Master Copy
Granted Queue
00ec0001 EX
Conversion Queue
Waiting Queue
01df0001 -- (PR) Remote:   2 01830001

morph-02:

Glock 0xf54ceedc (2, 22)
  gl_flags = 1
  gl_ref = 4
  gl_state = 0
  gl_owner = -1
  gl_ip = 0
  req_gh = yes
  req_bh = yes
  lvb_count = 0
  object = yes
  le = no
  reclaim = no
  aspace = 0xf54d869c nrpages = 0
  ail = 0
  Request
    owner = 4135 (chmod)
    gh_state = 3
    gh_flags = 3
    error = 0
    gh_iflags = 1 10
    initialized at: gfs2_getattr+0x63/0x9d [gfs2]
  Waiter3
    owner = 4135 (chmod)
    gh_state = 3
    gh_flags = 3
    error = 0
    gh_iflags = 1 10
    initialized at: gfs2_getattr+0x63/0x9d [gfs2]
  Waiter3
    owner = 4266 (bash)
    gh_state = 3
    gh_flags = 3
    error = 0
    gh_iflags = 1 10
    initialized at: gfs2_getattr+0x63/0x9d [gfs2]
  Inode: busy

Resource f5e2c780 Name (len=24) "       2              16"  
Local Copy, Master is node 1
Granted Queue
Conversion Queue
Waiting Queue
01830001 -- (PR) Master:     01df0001

 4073 S<   [dlm_astd]                  dlm_astd
 4074 S<   [dlm_scand]                 -
 4075 S<   [dlm_recvd]                 dlm_recvd
 4076 S<   [dlm_sendd]                 dlm_sendd
 4077 S<   [dlm_recoverd]              dlm_recoverd
 4114 S<   [lock_dlm1]                 gdlm_thread
 4116 S<   [lock_dlm2]                 gdlm_thread
 4117 S<   [dlm_recoverd]              dlm_recoverd
 4127 S<   [gfs2_scand]                -
 4128 S<   [gfs2_glockd]               gfs2_glockd
 4130 S<   [gfs2_recoverd]             -
 4131 S<   [gfs2_logd]                 -
 4132 S<   [gfs2_quotad]               -
 4134 Ss   qarshd                      -
 4135 D    chmod 777 /mnt/gfs_vs0      holder_wait
 4263 Ss   sshd: root@pts/1            -
 4266 Ds+  -bash                       holder_wait


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2007-05-10 15:09:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Steve Whitehouse 2007-05-11 08:56:36 EDT
I'm pretty sure this is fixed by the big update patch. There was an unlock that
was missing (or rather an extra ; that appeared where it shouldn't have been).


*** This bug has been marked as a duplicate of 239777 ***

Note You need to log in before you can comment on or make changes to this bug.