Bug 239743 - rhn5 code expect rhn5 schema to activate certificate
rhn5 code expect rhn5 schema to activate certificate
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Davis
Corey Welton
:
Depends On:
Blocks: 173432
  Show dependency treegraph
 
Reported: 2007-05-10 17:51 EDT by Matthew Davis
Modified: 2007-10-29 22:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 22:15:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Davis 2007-05-10 17:51:29 EDT
* Performing initial configuration.
* Activating Satellite.
Where is your satellite certificate file? /root/cert5
** Loading Satellite Certificate.
** Verifying certificate locally.
** Activating Satellite.
There was a problem activating the satellite: Local activation failure.


# cat /var/log/rhn/rhn-installation.log
<snip>
ERROR: RHN Entitlement Certificate failed to validate: 
Exception reported from fjs-0-09.rhndev.redhat.com
Time: Thu May 10 17:49:16 2007
Exception type exceptions.TypeError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/rhn_satellite_activate.py", line 200, in
activateSatellite_local
    satCerts.storeRhnCert(cert, check_generation=1)
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 227, in storeRhnCert
    set_slots_from_cert(sc)
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 128, in
set_slots_from_cert
    slot_type_id = slot_table[db_label]['id']
TypeError: unsubscriptable object
Comment 1 Matthew Davis 2007-05-10 18:00:56 EDT
Because there is a step in the upgrade process to activate the certificate,
activation of the cert during the upgrade is being skipped until after the
schema is upgraded.
Comment 3 Matthew Davis 2007-05-15 15:42:18 EDT
ON_QA
Comment 4 Corey Welton 2007-06-06 16:04:26 EDT
QA Verified, running in --disconnected alerts user that s/he will have to
activate afterwards.
Comment 5 Corey Welton 2007-06-20 09:37:07 EDT
release_pending
Comment 6 Brandon Perkins 2007-06-25 22:15:19 EDT
Closed for Satellite 500 Release.

Note You need to log in before you can comment on or make changes to this bug.