Bug 239760 - a quiet mode for grub
Summary: a quiet mode for grub
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard: bzcl34nup
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-11 03:57 UTC by Matthias Clasen
Modified: 2008-07-03 18:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 18:58:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ubuntu patch (6.48 KB, patch)
2007-05-11 03:57 UTC, Matthias Clasen
no flags Details | Diff
Silence grub completely (3.59 KB, patch)
2007-05-23 12:32 UTC, Pádraig Brady
no flags Details | Diff

Description Matthias Clasen 2007-05-11 03:57:47 UTC
It would be great to have a way to suppress all messages from grub.
(see http://fedoraproject.org/wiki/Releases/FeatureBetterStartup )

I'll attach the Ubuntu patch for this purpose. It seems buggy though,
since it initializes quiet_boot to 1 and has no way to reset it it 0.
The initial value should probably be 0, then we can turn on the feature
by putting "quiet" in the config file.

Comment 1 Matthias Clasen 2007-05-11 03:57:48 UTC
Created attachment 154515 [details]
Ubuntu patch

Comment 2 Ray Strode [halfline] 2007-05-11 14:19:49 UTC
Also, it seems to add a print statement:

+  grub_printf("Starting up ...\n");

Comment 3 Pádraig Brady 2007-05-23 12:32:55 UTC
Created attachment 155232 [details]
Silence grub completely

For reference here is the patch I've been using for a couple of years
to shut grub up completely. It should be easy to make it optionally shut up.

Comment 4 Jakub 'Livio' Rusinek 2007-11-26 17:50:47 UTC
So, what's the problem?

Comment 5 Bug Zapper 2008-04-04 00:38:29 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 6 Bug Zapper 2008-05-14 02:53:39 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Ray Strode [halfline] 2008-07-03 18:58:04 UTC
We're clear to close this one out now, yea, Peter?  We need to adjust the
default config I guess, still.


Note You need to log in before you can comment on or make changes to this bug.