Bug 239853 - pykickstart requirements
pykickstart requirements
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-11 14:02 EDT by Orion Poplawski
Modified: 2013-03-05 22:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 11:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-05-11 14:02:56 EDT
Description of problem:

I'm trying (perhaps foolishly) to run the livecd-tools on FC6.  Looks like it
requires a newer version of pykickstart than that available in FC6.  Perhaps a
versioned requires would be helpful.

Version-Release number of selected component (if applicable):
[root@saga fedora]# rpm -q pykickstart
pykickstart-0.36-1
[root@saga fedora]# livecd-creator
--config=/data/sw1/ks/livecd-fedora-cora-desktop.ks
Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 31, in ?
    import pykickstart.version
ImportError: No module named version
[root@saga fedora]# rpm -q livecd-tools
livecd-tools-008-1.fc6

(also, dosfstools needs to get updated for FC6, although the versioned
requirement in livecd-tools is not completely strict - livecd-tools doesn't run
dosfslabel directly)

lastly, it would be nice to the temp directory (currently /var/tmp) configurable.

Cool tool!
Comment 1 Jeremy Katz 2007-05-14 12:05:38 EDT
Looking at the possibility of pushing an update of pykickstart for FC6...
Comment 2 Chris Lumens 2007-05-14 16:06:33 EDT
A new pykickstart requires updating system-config-kickstart as well, since
otherwise that tool will be totally broken.  However, updating
system-config-kickstart is also going to require a new
system-config-securitylevel as the former uses the latter for one screen.  Do we
want to do all this?
Comment 3 Jeremy Katz 2007-09-13 11:07:45 EDT
Ended up bailing on doing a push for FC6.  livecd-tools requires Fedora 7 or later

Note You need to log in before you can comment on or make changes to this bug.