Bug 239880 - Error Resolving Dependency on Xen package update
Error Resolving Dependency on Xen package update
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-11 16:39 EDT by Russell Doty
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 14:35:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Doty 2007-05-11 16:39:16 EDT
Description of problem:

YUM reports updated Xen packages available. Upon running Yum, receive error
resolving dependencies: Missing Dependency: "xen-libs = 3.0.3-25.el5 is needed
by package xen". This package is installed on the system.

Version-Release number of selected component (if applicable):

RHEL 5.0 Workstation with Multi-OS Option.

How reproducible:

Every time.

Steps to Reproduce:
1. Run Package Updater
2. Select Updated Xen packages
3. Apply updates
  
Actual results:

Dependency error

Expected results:

Updated package installed.

Additional info:
Comment 1 Kevin Otte 2007-05-18 14:07:10 EDT
Output from "yum update" on a RHEL 5 install with all other updates applied:

[root@beulah ~]# yum update
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
rhel-i386-server-5        100% |=========================| 1.2 kB    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-xen.i686 0:2.6.18-8.1.4.el5 set to be installed
---> Package xen-libs.i386 0:3.0.3-25.0.3.el5 set to be updated
--> Running transaction check
--> Processing Dependency: xen-libs = 3.0.3-25.el5 for package: xen
--> Finished Dependency Resolution
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-xen.i686 0:2.6.18-8.1.3.el5 set to be erased
--> Running transaction check
--> Processing Dependency: xen-libs = 3.0.3-25.el5 for package: xen
--> Finished Dependency Resolution
Error: Missing Dependency: xen-libs = 3.0.3-25.el5 is needed by package xen
Comment 2 Daniel Berrange 2007-05-18 14:23:00 EDT
Sounds like your yum repositories are not configured correctly / missing
packages. What site are your downloading from for the rhel-i386-server-5 
repository ? Please provide the config files /etc/yum.repos.d/ if possible. 
Comment 3 Russell Doty 2007-05-18 18:05:18 EDT
Note that all other updates - including updates to other xen packages - install
correctly.


Contents of rhel-debuginfo.repo:

[rhel-debuginfo]

name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/$basearch/Debuginfo/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release



contents of installonlyn.conf

[main]
enabled=1
# this sets the number of package versions which are kept
tokeep=2


contents of rhnplugin.conf


[main]
enabled = 1
gpgcheck = 1


contents of yumupdatesd.conf

[main]
# how often to check for new updates (in seconds)
run_interval = 3600
# how often to allow checking on request (in seconds)
updaterefresh = 600

# how to send notifications (valid: dbus, email, syslog)
emit_via = dbus

# automatically install updates
do_update = no
# automatically download updates
do_download = no
# automatically download deps of updates
do_download_deps = no

Comment 4 James Ralston 2007-07-18 12:10:02 EDT
We ran into this as well.

The problem is that even though the xen RPMs are included in the RHEL5 ISO
images you can download via RHN, there is a separate virtualization child
channel for RHEL5, and updates are split across both the main and child channels
(e.g., the xen-libs package is in the main channel, but the xen package is in
the child channel).

In order to get access to all virtualization packages, you need to subscribe to
the "RHEL Virtualization" child channel via RHN.  Once you do that, you'll have
access to all of the virtualization-related RPMs, and yum will be able to
resolve its missing dependencies.
Comment 5 Robert Boyd 2007-10-24 14:28:10 EDT
This suggestion that there is a "need" to subscribe to the Virtualization child
channel seems like a problem that needs to be fixed.   This is NOT an obvious
fix to a problem like this.   We experienced the problem immediately upon
installing the system and setting it up to pull down updates from our RHN
Satellite Server.  

A workaround I discovered for getting our system updated was to do:
yum remove xen
yum update

The update then successfully updated all of the errata and such, and it
installed xen-kernel.  We haven't started trying to use xen yet. We may need to
subscribe to the child channel and install the related packages to get all of
the capabilities back.  I'm not sure how many of the pieces of xen are actually
on the system at this point.  
Comment 6 Daniel Berrange 2007-10-24 14:35:33 EDT
In the RHEL-5 installation, Anaconda will ask for an 'Installation number'. If
you have an installation number which includes the virtualization capabilities,
you will automatically be subscribed to the correct RHN child channels for Xen.
Otherwise you'll have to do it manually. For more informaiton about installation
numbers read this page

http://www.redhat.com/support/resources/faqs/installation_numbers/

Or contact the appropriate customer services number for assistance with
installation.

http://www.redhat.com/about/contact/dir/#custservice

Note You need to log in before you can comment on or make changes to this bug.