Bug 239937 - yum-updatesd: not receiving updates or update notifications
yum-updatesd: not receiving updates or update notifications
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-12 18:11 EDT by Need Real Name
Modified: 2014-01-21 17:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 14:05:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-05-12 18:11:48 EDT
I'm not receiving notifications of updates through yum-updatesd.

$ cat /etc/yum/yum-updatesd.conf 
[main]
# how often to check for new updates (in seconds)
run_interval = 3600
# how often to allow checking on request (in seconds)
updaterefresh = 600

# how to send notifications (valid: dbus, email, syslog)
emit_via = dbus

# automatically install updates
do_update = no
# automatically download updates
do_download = yes
# automatically download deps of updates
do_download_deps = yes
Comment 1 Jeremy Katz 2007-05-14 14:42:04 EDT
What version of yum do you have installed?
Comment 2 Need Real Name 2007-05-14 15:22:57 EDT
yum-updatesd-3.1.7-2.fc7
Comment 3 Need Real Name 2007-06-21 17:31:34 EDT
This problem remains, I never receive a security update unless I run yum -y
upgrade manually, which then downloads the packages and dependencies, and
installs them. It seems that yum-updatesd is doing nothing, apart from hogging a
lock file.

$ rpm -q yum yum-updatesd
yum-3.2.0-1.fc7
yum-updatesd-3.2.0-1.fc7
Comment 4 Need Real Name 2007-06-24 12:10:08 EDT
The problem is actually worse, because yum-updatesd constantly hogs the lockfile:

# yum -y upgrade
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading "protectbase" plugin
Loading mirror speeds from cached hostfile
Existing lock /var/run/yum.pid: another copy is running as pid 2783. Aborting.

# strace -p 2783
Process 2783 attached - interrupt to quit
gettimeofday({1182701127, 375021}, NULL) = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x86c1350, FUTEX_WAKE, 1)         = 0
gettimeofday({1182701127, 375637}, NULL) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 1000) = 0
gettimeofday({1182701128, 376043}, NULL) = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x86c1350, FUTEX_WAKE, 1)         = 0
gettimeofday({1182701128, 377389}, NULL) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 1000) = 0
gettimeofday({1182701129, 377599}, NULL) = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x83dc170, FUTEX_WAKE, 1)         = 0
futex(0x86c1350, FUTEX_WAKE, 1)         = 0
gettimeofday({1182701129, 378866}, NULL) = 0
etc.
Comment 5 Valdis Kletnieks 2007-06-25 23:29:24 EDT
Am still seeing this as of yum 3.2.1-1.fc8
Comment 6 Need Real Name 2007-06-28 15:45:52 EDT
To workaround (hide) the "can't use yum at all, because yum-updatesd is hogging
the lockfile", I used the following options:
 do_download = no
 do_download_deps = no
I can them restart yum-updatesd, run yum -y upgrade, then change the options back.
Comment 7 Peter Bieringer 2007-07-07 04:32:35 EDT
Looks like I have similiar problem on my laptop. After fresh booting into
runlevel 5 and log in as user, I get soon the message, that some updates are
available. My all-day workflow is now to suspend the laptop after use and wake
it up if needed (it's up for sure longer than 1 hour then).
Since the first update cycle, no other appears again, while yum-updatesd is
still running (looking into process table).
Have to run a manual "yum update" for further updates now.
Can it be, that something is not working proper in the interval section?

My settings:

# how often to check for new updates (in seconds)
run_interval = 3600
# how often to allow checking on request (in seconds)
updaterefresh = 600

# how to send notifications (valid: dbus, email, syslog)
emit_via = dbus


Is there any debug option available?
Comment 8 I. Piasecki 2007-07-10 16:25:25 EDT
Hi.

I have the same behaviour of yum-updatesd, se i'm to !

yum-updatesd working only when, i log in GNOME. After 8 or more hours of wrok, i
don't get info about updates, even if some are available.

System: Fedora 7 (updated from Fedora Core 6)
yum: 

yum-presto-0.3.10-1.fc7
yum-3.2.1-1.fc7
yum-metadata-parser-1.1.0-2.fc7
yum-fastestmirror-1.1.5-1.fc7
yumex-1.9.9-1.0.fc7
yum-utils-1.1.5-1.fc7
yum-updatesd-3.2.1-1.fc7

In FC6 tis were the same, yum-updatesd don't inform about new updates ... ?

What about this would say author of yum-updatesd:  Jeremy Katz and others ?
Comment 9 Thomas J. Baker 2007-07-24 09:25:27 EDT
With the settings the same as #1, I almost never receive an update notification
on my F7 workstation. (I say almost never because I can't ever remember
receiving one but I have many systems and could be wrong.) Just now I log in,
and there's no notification of updates. I then do a yum update and there's 10
updates available. I know that some of these updates were available yesterday
because I updated my laptop.
Comment 10 I. Piasecki 2007-07-25 00:17:49 EDT
As we see, who cares about this crappy yum-updatesd ?? up2date was good - it was
working - but yum-updatesd not. Maybe in Fedora12 it will be with good
production quality, as now is simply crappy and i sugest switch it off.
Comment 11 Matt Castelein 2007-07-25 16:20:54 EDT
Same behaviour here, No update email ever gets sent although there are updates
available.

yum-updatesd-3.2.1-1.fc7
Comment 12 Tim W 2007-07-29 14:13:58 EDT
Actually, the yum-updatesd in FC6 worked extremely well, and even in F7T4 it
also worked properly.  Now to get updates, I have to stop the yum-updatesd
service and then do the updates manually.  I much preferred when the
notification alerted me of updates so I could choose whether or not to install them.

---

My typical update script:

#! /bin/bash
service yum-updatesd stop && yum update
service yum-updatesd start


And my yum-updatesd.conf:

[main]
# how often to check for new updates (in seconds)
run_interval = 3600
# how often to allow checking on request (in seconds)
updaterefresh = 600

# how to send notifications (valid: dbus, email, syslog)
emit_via = dbus

# automatically install updates
do_update = no
# automatically download updates
do_download = yes
# automatically download deps of updates
do_download_deps = yes

Comment 13 Gérard Milmeister 2007-08-01 09:16:35 EDT
Similar problem here. On a reboot and login into GNOME, updates are shown
correctly by puplet. But afterwards no new updates are shown, even if there are
some.
Comment 14 Seth Vidal 2007-08-03 15:34:47 EDT
If you get the chance - try yum-updatesd from rawhide. If it doesn't fix this
problem reopen the bug.
Comment 15 I. Piasecki 2007-08-03 18:06:16 EDT
Ok, here you are:

yumex-1.9.10-2.0.fc7
yum-fastestmirror-1.1.6-1.fc7
yum-presto-0.3.10-1.fc7
yum-utils-1.1.6-1.fc7
keyutils-libs-1.2-2.fc6
yum-metadata-parser-1.1.0-2.fc7
keyutils-libs-1.2-2.fc6
yum-updatesd-0.4-1.fc8
yum-3.2.2-1.fc7

let's try this stuff again ...
Comment 16 Need Real Name 2007-08-05 12:21:33 EDT
To increase the chance of other people trying this, here is the copy and paste
version:
 yum --enablerepo=development upgrade yum-updatesd

I've installed it and will test with the next yum update.
Comment 17 Need Real Name 2007-08-07 06:00:15 EDT
Doesn't work for me. In /etc/yum/yum-updatesd.conf I have:

# how often to check for new updates (in seconds)
run_interval = 3600

but after three hours, and a restart of yum-updatesd (and even lowering the
interval) I still get no update notifications. Running yum -y upgrade appears
not to download anything however.
Comment 18 Need Real Name 2007-08-07 06:01:12 EDT
yum-updatesd-0.4-1.fc8
Comment 19 Jeff 2007-08-07 09:03:58 EDT
It's working for me with "do_update = yes". You might want to give it another
day - perhaps the mirror you're connecting to hasn't yet got the latest updates. 
Comment 20 Thomas J. Baker 2007-08-07 10:01:13 EDT
There's seems to be at least one bug with the rawhide version. With do_download
and do_download_deps set to yes, when there are no updates, it displays the
"Automatic update installation failed!" icon. 

I've had it installed for several days and I'm not sure if it's solved the
problem or not. For instance this morning, I unlocked my desktop after having it
locked all night, saw that updatesd was not showing anything, yum updated,
rebooted, and on logging in, it showed the Auto updates failed message.
Comment 21 Thomas J. Baker 2007-08-07 10:06:31 EDT
Just unhibernated my laptop and it's not showing updates that are there when
running yum by hand. I don't know if the checking interval just sleeps 3600
seconds and a hibernate in the middle wouldn't register or if it checks
periodically for 3600 seconds passing on the clock.
Comment 22 Valdis Kletnieks 2007-08-07 11:10:49 EDT
Since yesterday, I've been looking at 331 (yes, 331) updates that 'yum list
updates' is reporting as being there, and which I've hand-verified are present
on the mirrors, but which aren't downloading.  But over 24 hours later,
yum-updatesd is still sitting there refusing to download the updates (I have a
config basically identical to Tim's from #12.

yum-updatesd-0.4-1.fc8

Oh well, probably time to 'chkconfig yum-updatesd off' again, until there's some
indication that it's actually fixed.

If I didn't know better, I'd say the behavior is identical to what I'd expect if
the code was doing this:

if (do_update) {
    install_updates;
    if (do_download) {
        download_updates;
        if (prereqs) {
            download_prereqs;
        }
     }
}

Rather than this:

if {do_update) {
   install_updates;
} else if (do downloads) {
   download_updates;
   if (prereqs) {
        download_prereqs;
   }
}

Is this a case where we got bit by the Python indents-as-syntax weirdness?
Comment 23 I. Piasecki 2007-08-07 14:28:06 EDT
Is there any debug level settings for yum-updatesd ? Nobody knows, what exctly
this stuff doing, i know that sits on my systems and use resources.

And one question - it is not so clear for me: when i got info, that there are
updates available but i click -> quit in puplet (???) dialog, so i will get info
again when yum-updatesd will check in some interval ? Puplet/yum-updatesd icon
will be appear again near my clock ?
Comment 24 Thomas J. Baker 2007-08-07 15:00:36 EDT
Just as an update to #21, I let the laptop sit several hours and no updates were
reported as being available even though yum reports 3 packages to be updated.
Comment 25 Thomas J. Baker 2007-08-07 17:04:42 EDT
FWIW, it seems to work perfectly on my F8T1 test system. The config file is
stock - no installing or downloading are enabled - and it's worked fine twice
today. Problems must be related to downloading but not installing. I'm going to
reset to stock config on my f7 desktop as a test.
Comment 26 Need Real Name 2007-08-07 17:26:07 EDT
TJB - The issue is only with non-stock configurations.
Comment 27 Need Real Name 2007-08-08 15:26:38 EDT
I just rebooted, and I am shown updates. This is odd.
 yum-updatesd-0.4-1.fc8
Comment 28 Need Real Name 2007-08-14 11:30:04 EDT
WFM on both boxes.
Comment 29 Valdis Kletnieks 2007-08-14 14:46:36 EDT
lsof: #28 - What does your config file look like now that it's working?  Do you
still have 'do_update=no' and 'do_download=yes', or did an RPM install overlay it?

(Am at 0.4-1.fc8, and it's still broken for me).
Comment 30 Need Real Name 2007-08-15 04:43:45 EDT
yum-updatesd-0.4-1.fc8 - did you restart it?

$ cat /etc/yum/yum-updatesd.conf
[main]
# how often to check for new updates (in seconds)
run_interval = 3600
# how often to allow checking on request (in seconds)
updaterefresh = 600

# how to send notifications (valid: dbus, email, syslog)
emit_via = dbus

# automatically install updates
do_update = no
# automatically download updates
#do_download = no
do_download = yes
# automatically download deps of updates
#do_download_deps = no
do_download_deps = yes


$ units
2439 units, 71 prefixes, 33 nonlinear units

You have: 3600 seconds
You want: hours
        * 1
        / 1
Comment 31 Peter Bieringer 2007-08-17 02:34:40 EDT
yum-updatesd-0.4-1.fc8

Did anyone else see silent crashes of yum-updatesd? Looks like it happens to me
here several times on a laptop at least after resume.

BTW: man page of yum-updatesd needs to be updated, it understand at least option
"--debug", "--no-fork" and "--oneshot".

Comment 32 Need Real Name 2007-08-21 15:58:17 EDT
I didn't see any crashes (well, it appears in the process list anyway..)

yum-updatesd is definitely noticing updates at boot, but later than that? I'm
not sure...

Seth (or anyone) - how can we help you fix this?
Comment 33 I. Piasecki 2007-09-05 18:29:30 EDT
This yum-updatesd.noarch 3.2.4-2.fc7 is a BIG SHIT OF CRAPPY APPS

Does'nt work at all and eat 25% of installed memory: 512MB /4 = circa 128MB and
give me 0 (zero) info abou updates available for my F7. What a mistake ...

Hey authors, why you waste your energy for this shitty aps ? yum-updatesd from
rawhide   worked like a champ. He always told me about updates and hear me: IT
WORKS in fedora7 to ! But you still have for Fedora7 this broken version of
yum-updatesd. Are you silly or simply ...

STOP this crappy apps and give us good working version of yum-updatesd. This bug
was open in May 2007. Now there is September 2007 - 4 months and no good
progress in this matter. I bet, there are many people around, whose don't use
yum in shell and their fedoras aren't updated cause this stupid yum-updatesd. So ??

Ubuntu also has problems with infromation in desktop about updates, as we have
with our crappy yum-updatesd ? I saw, they don't have.  Wake up !

Comment 34 I. Piasecki 2007-09-13 18:47:16 EDT
In F7 i have yours yum-updatesd deep in my ...
Comment 35 Valdis Kletnieks 2007-09-18 13:49:16 EDT
yum-updatesd-0.5-2.fc8 and it's *still* busticated.

# cat 
# how often to check for new updates (in seconds)
run_interval = 3600
# how often to allow checking on request (in seconds)
updaterefresh = 600

# how to send notifications (valid: dbus, email, syslog)
emit_via = email
# should we listen via dbus to give out update information/check for
# new updates 
dbus_listener = no

# automatically install updates
do_update = no
# automatically download updates
do_download = yes
# automatically download deps of updates
do_download_deps = yes

But it's been 4 hours, and yum-updatesd has *yet* to download even *one*
package. Meanwhile, 'yum update' reports:

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update     153 Package(s)         
Remove       1 Package(s)         

Total download size: 294 M
Is this ok [y/N]: 

I'm beginning to think that this is related to bug #291871 - both this bug and
that one would be explained if the yum-updatesd process is just sitting there
twiddling its thumbs and refusing to wake up for any annoying things like timer
events and refresh requests.

Anybody know how to do a Python-level traceback on a running process?


Comment 36 Need Real Name 2007-10-22 13:30:14 EDT
yum-updatesd-0.7-1.fc8 WFM!
Comment 37 Valdis Kletnieks 2008-01-05 03:26:12 EST
So I finally decide to give yum-updatesd another try, since it's now revved all
the way up to yum-updatesd-0.9-1.fc9.  I do a 'service yum-updatesd start', and
just about an hour later (which matches up with the  'run_interval=3600'), it
actually *does* something.  It sends me an e-mail that says:

"Hi,
This is the automatic update system on turing-police.cc.vt.edu.

There was a problem updating the system. The following error message
was reported:

Failed to build transaction: Missing Dependency: xorg-x11-server-Xorg >=
1.4.99.1 is needed by package xorg-x11-drv-mga
Missing Dependency: xorg-x11-server-Xorg >= 1.4.99.1 is needed by package
xorg-x11-drv-ati
Missing Dependency: xorg-x11-server-Xorg >= 1.4.99.1 is needed by package
xorg-x11-drv-savage
Missing Dependency: tetex-fonts is needed by package a2ps
Missing Dependency: xorg-x11-server-Xorg >= 1.4.99.1 is needed by package
xorg-x11-drv-i810

If the problem persists, manual intervention may be required."

OK, a fair call on its part - a2ps needs revving for the recent texlive changes,
and there's some xorg issues due to the NVidia drivers not liking 1.4.99, so I
have an exclude= for it.

The only problem is that I have in the yum-updatesd.conf "do_update = no" and"
do_download = yes" - and it *still* didn't actually download any of the updates,
and the biggest "problem updating the system" is that it *tried* to update it
rather than just download the stuff.

Anybody know why I'm having so much trouble getting it to do a fairly simple
thing (download the updates and let me know, and I'll apply them if/when I'm
ready)? (for the record, my yum-updatesd.conf is unchanged from comment #35)
Comment 38 Valdis Kletnieks 2008-01-05 04:24:37 EST
And it's apparently decided to spam me with "there was a problem updating your
system" every 3600 seconds.  Good thing I didn't chkconfig on that sucker, and
it's gone when I reboot. ;)
Comment 39 James Antill 2008-01-06 17:15:12 EST
 After you changed the config. did you restart it? It doesn't automatically
reload it's config. file.
Comment 40 Valdis Kletnieks 2008-01-07 13:07:38 EST
% ls -l /etc/yum/yum-updatesd.conf 
-rw-r--r-- 1 root root 493 2007-09-18 15:44 /etc/yum/yum-updatesd.conf
% last | grep reboot
reboot   system boot  2.6.24-rc5-mm1   Mon Jan  7 11:06          (01:57)    
reboot   system boot  2.6.24-rc5-mm1   Sun Jan  6 02:48         (1+07:56)   
reboot   system boot  2.6.24-rc5-mm1   Sat Jan  5 22:22          (03:27)    
reboot   system boot  2.6.24-rc5-mm1   Sat Jan  5 06:06          (15:48)    
reboot   system boot  2.6.24-0.133.rc6 Sat Jan  5 06:04          (00:00)    
reboot   system boot  2.6.24-rc5-mm1   Fri Jan  4 14:14          (15:30)
    (The above uptime covers the time I was testing on 01/05)
reboot   system boot  2.6.24-rc5-mm1   Fri Jan  4 02:14          (11:16)    
reboot   system boot  2.6.24-rc5-mm1   Fri Jan  4 02:12          (11:18)    
reboot   system boot  2.6.24-rc5-mm1   Thu Jan  3 20:45          (04:50)    
reboot   system boot  2.6.24-rc5-mm1   Thu Jan  3 00:43          (15:57)    
reboot   system boot  2.6.24-rc5-mm1   Wed Jan  2 10:08          (07:44)    
reboot   system boot  2.6.24-rc5-mm1   Tue Jan  1 11:41          (21:36)

So yeah, there were a *lot* of reboots, and it got restarted with the config
file that has been there since the config listed in comment #35 (almost 3 months
ago)
Comment 41 James Antill 2008-01-07 13:22:30 EST
 Sorry, I thought you'd changed do_update from yes to no ... given that it was
doing the depsolve. But if you have do_download_deps as yes then that'll also
require a depsolve, which will trigger the depsolve problem.
Comment 42 Valdis Kletnieks 2008-01-07 13:44:26 EST
OK, I can live with it complaining that dependencies are missing, but I'll note
2 things:

1) It should be able to *download* non-problematic updates (and possibly even
download ones that have problems), because it can't predict what conditions will
exist when the actual 'update' command is issued. For instance, there was a
*big* bunch of packages that got piled up recently because I had *one*
third-party RPM that was still dependent on the older version of the openssl
libraries. I ended up doing an 'rpm -e' of the one package - at which point 'yum
update' was able to apply everything.  In that case, yum-updatesd should
probably have downloaded all the dependents of the openssl update because they
were *speculatively* applicable, even if they weren't actually installable. 
(Note that batch of updates was literally about 300M, and the entire reason I'm
trying to run it in download_only is because there are times when I have lots of
bandwidth when I'm *not* in a position to update, and good times to update I
often have limited bandwidth - basically, "suck it down at gigabit at work and
apply it in the evening at home").

2) If it *knows* it's only downloading, it should say "There was a problem
downloading the updates" rather than "There was a problem updating the system".
If anything, that's an even *bigger* problem - it certainly surprised me that it
claimed an update was attempted when I was *sure* I had told it not to (after
all, when you're syncing to rawhide, automatic unattended updates are probably
Bad Karma Waiting).

Note You need to log in before you can comment on or make changes to this bug.