Bug 239992 - Python module segfaults after popHelpLine
Python module segfaults after popHelpLine
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: newt (Show other bugs)
6
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-14 03:49 EDT by George Goh
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.52.7-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 12:14:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Code that causes segfault. (238 bytes, text/plain)
2007-05-14 03:53 EDT, George Goh
no flags Details
Code that solves the problem. (263 bytes, text/plain)
2007-05-14 03:53 EDT, George Goh
no flags Details

  None (edit)
Description George Goh 2007-05-14 03:49:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; InfoPath.2)

Description of problem:
When creating one snackScreen after another continuously, I reliably get a segfault after 168 runs of the attached code(try.py). However, using try2.py, I was able to get 500 runs with no problems.

This bug was quite obscure because it did not show up immediately. In this example it does take a large number of runs for the bug to surface. Perhaps a check should be made to check if a helpline already exists before letting the caller pushHelpLine.

Version-Release number of selected component (if applicable):
newt-0.52.2-9

How reproducible:
Always


Steps to Reproduce:
1.Run try.py
2.Notice that it segfaults after 167 runs
3.Run try2.py
4.No segfaults.

Actual Results:


Expected Results:


Additional info:
Comment 1 George Goh 2007-05-14 03:53:05 EDT
Created attachment 154624 [details]
Code that causes segfault.
Comment 2 George Goh 2007-05-14 03:53:40 EDT
Created attachment 154625 [details]
Code that solves the problem.
Comment 3 Miroslav Lichvar 2007-05-14 11:01:49 EDT
Thanks for the report.

SnackScreen with each initialization calls pushHelpLine to have the default help
string, the stack keeps growing and there is no check for overflow.
Comment 4 Miroslav Lichvar 2007-05-15 06:47:27 EDT
Fixed in upstream CVS, will be in the next release.
Comment 5 Miroslav Lichvar 2007-06-15 09:23:04 EDT
Fixed in newt-0.52.7-1.fc8.
Comment 6 Fedora Update System 2007-08-09 12:48:48 EDT
newt-0.52.7-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2007-08-17 12:14:00 EDT
newt-0.52.7-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.