Bug 240082 - Resume from suspend fails when kvm/kvm_intel loaded on Lenovo X60
Resume from suspend fails when kvm/kvm_intel loaded on Lenovo X60
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 242333 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-14 19:37 EDT by James Bowes
Modified: 2013-01-10 04:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 10:54:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2007-05-14 19:37:35 EDT
With the kvm/kvm_intel modules loaded, my laptop will suspend to ram, but will
never resume. There will be some hard disk activity, but the little moon sleep
light will stay on. caps lock keys etc do not work either. Unloading the kvm
modules allows suspend and resume to work properly.

Some details:
kernel-2.6.21-1.3149.fc7.i686

$> lshal | grep system.hardware.version
  system.hardware.product = '1709G3U'  (string)

Intel(R) Core(TM)2 CPU T7200 @2.00GHz
Comment 1 Richard Hughes 2007-05-24 06:45:29 EDT
Does this still happen with the latest rawhide kernel? Thanks.
Comment 2 James Bowes 2007-05-24 08:58:10 EDT
Sadly, I can't tell. Something else is breaking suspend/resume with kernel
2.6.21-1.3194. I'll update this bug when I can determine if KVM is a problem or not.
Comment 3 Jonathan Underwood 2007-06-04 18:10:17 EDT
*** Bug 242333 has been marked as a duplicate of this bug. ***
Comment 4 Jonathan Underwood 2007-06-04 18:12:18 EDT
As I mentioned in 242333, I see the same thing on a Dell XPS M1210.

Having the following in /etc/pm/config.d/unload_modules fixes the problem,
allowing the machine to resume:

SUSPEND_MODULES="iwl3945 mac80211 kvm_intel kvm"

removing kvm_intel and kvm from that list renders the system unable to resume.

I wonder if the kvm patches mentioned here for the kernel are any help:

http://www.ussg.iu.edu/hypermail/linux/kernel/0706.0/0025.html

Comment 5 Richard Hughes 2007-06-05 05:04:01 EDT
(In reply to comment #4)
> removing kvm_intel and kvm from that list renders the system unable to resume.

I've added this to the suspend site, thanks.

Richard.
Comment 6 Patrick C. F. Ernzer 2007-06-15 08:54:52 EDT
To make for a smoother user experience, can we do one of these please (by order
of preference)?

  - make the kvm kernel modules handle suspend
  - make the kvm kernel modules self-unload on sleep
  - drop a file in /etc/pm/sleep.d/ to make sure kvm-amd, kvm-intel and kvm are 
on the SUSPEND_MODULES list

Thanks

PCFE
Comment 7 Avi Kivity 2007-07-23 04:54:24 EDT
2.6.23-rc1 now has reliable suspend-to-ram.  It should be easy to backport the 
patches to earlier kernels.
Comment 8 Richard Hughes 2007-07-23 05:01:03 EDT
>2.6.23-rc1 now has reliable suspend-to-ram.

Agreed, you guys rock. DaveJ, can we add this to the F7 kernel when you next do
a rebuild?
Comment 9 Jonathan Underwood 2008-01-11 19:15:36 EST
As far as i can tell, this bug is fixed in F-7 and F-8, and could be closed.
Comment 10 James Bowes 2008-01-14 10:54:54 EST
(In reply to comment #9)
> As far as i can tell, this bug is fixed in F-7 and F-8, and could be closed.

Agreed. I'll close it.

Note You need to log in before you can comment on or make changes to this bug.