Bug 240088 - Yumex crashes on startup.
Yumex crashes on startup.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-14 20:47 EDT by Renato de Oliveira Diogo
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 02:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renato de Oliveira Diogo 2007-05-14 20:47:48 EDT
+++ This bug was initially created as a clone of Bug #214831 +++

Description of problem:

Since upgrading to FC6, Yumex no longer works.  An error message appears and
requests to post the problem to this repository.  Here is the error message:

Component: yumex
Version: 1.1.7
Summary: TBf0b64ae8 updates.py:584:getObsoletesList:AttributeError: Updates
instance has no attribute 'obsoletes'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1102, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 536, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 990, in setup_yum
    self.yumexbase.build_package_lists( self.recentlimit, pkglists )
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 449, in
build_package_lists
    updates = self.up.getUpdatesList() + self.up.getObsoletesList()
  File "/usr/lib/python2.4/site-packages/rpmUtils/updates.py", line 584, in
getObsoletesList
    tmplist = self.obsoletes.keys()
AttributeError: Updates instance has no attribute 'obsoletes'

Local variables in innermost frame:
newest: 0
self: <rpmUtils.updates.Updates instance at 0x9e412ec>
arch: None
name: None





Version-Release number of selected component (if applicable):

Version: 1.1.7

How reproducible:

Every time Yumex is loaded.  It worked fine in FC5.

Steps to Reproduce:
1. Open Yumex
2. It crashes during initialization after a few minues.
3.
  
Actual results:


Expected results:


Additional info:

-- Additional comment from gregory.douglas@sympatico.ca on 2006-11-09 12:39 EST --
*** Bug 214823 has been marked as a duplicate of this bug. ***

-- Additional comment from tla@rasmil.dk on 2006-11-10 02:26 EST --
do you have a
obsoletes=1
in /etc/yum.conf

place attach your /etc/yum.conf

-- Additional comment from tla@rasmil.dk on 2006-11-10 04:09 EST --
Ok, it dont check for the obsoletes setting, it should be fixed in yumex 1.2,
just released.


Hi, my yumex (last updated) is crashes in startup. The bug window report this:
====
Component: yumex
Version: 1.2.3
Summary: TB3638d33a ConfigParser.py:511:get:NoSectionError: No section: 'main'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1115, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 507, in __init__
    self.profile = Profile()
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 1202, in
__init__
    self.active=self.profiles.get( "main", "LastProfile" )
  File "/usr/lib/python2.4/ConfigParser.py", line 511, in get
    raise NoSectionError(section)
NoSectionError: No section: 'main'

Local variables in innermost frame:
d: {}
vars: None
self: <ConfigParser.ConfigParser instance at 0x89f18cc>
raw: False
section: main
option: LastProfile
====

At moment don't have updated this apps.

[]s
Comment 1 Tim Lauridsen 2007-06-12 02:46:50 EDT
Yum have to yumex 1.2.x with FC6 and i look like there is a problem with
/etc/yumex.profiles.conf

The default look like this

[tim@localhost ~]$ cat /etc/yumex.profiles.conf 
[main]
lastprofile = yum-enabled

Note You need to log in before you can comment on or make changes to this bug.