Bug 240275 - at jobs fail to run
at jobs fail to run
Status: CLOSED DUPLICATE of bug 243064
Product: Fedora
Classification: Fedora
Component: at (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
:
: 244203 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 02:47 EDT by Daryll
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 09:22:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daryll 2007-05-16 02:47:48 EDT
Running: at-3.1.10-11.fc7

The first problem is that it appears the atd dies. It is chkconfig'd to run at
boot, but isn't running when I submit my job.

I submit a job for at which appears to work correctly.

I then manually run the atd. 

When the time comes for the job to execute /var/log/messages says:
May 15 22:50:01 ninja atd[6947]: Open of jobfile failed: Success
and the atd dies again.
Comment 1 Marcela Mašláňová 2007-05-17 09:23:55 EDT
I tried touch /tmp/file | at now
The message is the same, but the job was successful. Do you have the same problem?
Comment 2 Daryll 2007-05-17 10:44:06 EDT
I assume you mean you did:

echo touch /tmp/file | at now

(because what you wrote would have worked fine)

If I echo touch /tmp/file | at now

I get the warning "at daemon not running" and the job ends up in the queue.

Also I just realized I have to be root to do an atrm which is wrong. I should be
able to remove my own at jobs. Maybe that points to a permission problem somewhere?


Comment 3 Marcela Mašláňová 2007-06-25 09:22:07 EDT

*** This bug has been marked as a duplicate of 243064 ***
Comment 4 Marcela Mašláňová 2007-06-25 09:23:39 EDT
*** Bug 244203 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.