Bug 24032 - PANIC on laptop after suspend and resume
PANIC on laptop after suspend and resume
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i586 Linux
high Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-15 11:44 EST by Dieter Kasper
Modified: 2007-03-26 23:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 13:08:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
problem description with more details (9.47 KB, text/plain)
2001-01-15 11:54 EST, Dieter Kasper
no flags Details

  None (edit)
Description Dieter Kasper 2001-01-15 11:44:44 EST
I installed Redhat-7 from linux-central on my notebook.
Every time after a suspend to disk and resume
I got a PANIC while accessing network service from inside
the notebook or from outside.
With Redhat 6.1 and identical hardware I never had this problem!

search for 'EIP:'

--- /var/log/messages --- BEGIN
Jan  9 20:20:00 oder CROND[1340]: (root) CMD (   /sbin/rmmod -as)
Jan  9 20:20:30 oder cardmgr[479]: executing: './network suspend eth0'
Jan  9 20:20:30 oder kernel: eth0: interrupt from stopped card
Jan  9 20:20:30 oder cardmgr[479]: executing: './network suspend eth1'
Jan  9 20:20:30 oder cardmgr[479]: executing: './serial suspend ttyS3'
Jan  9 20:20:30 oder apmd[380]: User Suspend
Jan 10 07:15:00 oder apmd[380]: Now using Battery
Power                         Jan 10 07:15:00 oder apmd[380]: Battery:
0.025384 (11:10) 2 days, 5:50 (82% 2 days, 18:44)
Jan 10 07:15:01 oder kernel: eth1: media 10Base2, silicon revision
4            Jan 10 07:15:01 oder cardmgr[479]: executing: './network
resume eth0'
Jan 10 07:15:01 oder cardmgr[479]: executing: './network resume eth1'
Jan 10 07:15:02 oder cardmgr[479]: executing: './serial resume ttyS3'
Jan 10 07:15:05 oder apmd[380]: Normal Resume after 10:54:35, -15.40%/day
(82% 2 days, 18:44) Battery power
Jan 10 07:15:29 oder CROND[1407]: (root) CMD (   /sbin/rmmod -as)
Jan 10 07:15:29 oder CROND[1408]: (root) CMD (run-parts /etc/cron.hourly)
Jan 10 07:15:29 oder CROND[1409]: (root) CMD (run-parts /etc/cron.daily)
Jan 10 07:15:30 oder anacron[1413]: Updated timestamp for job `cron.daily'
to 2001-01-10
Jan 10 07:16:11 oder kernel: invalid operand: 0000
Jan 10 07:16:11 oder kernel: CPU:    0
Jan 10 07:16:11 oder kernel: EIP:    0010:[ip_route_output_slow+944/1336]
Jan 10 07:16:11 oder kernel: EFLAGS: 00010297
Jan 10 07:16:11 oder kernel: eax: 00000001   ebx: c79dbe64   ecx:
485e19ac   edx: 485e19ac
Jan 10 07:16:11 oder kernel: esi: cfff6484   edi: 00000000   ebp:
485e19ac   esp: c79dbe44
Jan 10 07:16:11 oder kernel: ds: 0018   es: 0018   ss: 0018
Jan 10 07:16:11 oder kernel: Process newaliases (pid: 1337, process nr: 64,
stackpage=c79db000)
Jan 10 07:16:11 oder kernel: Stack: 485e19ac 00000000 c79dbe54 c79dbe54
cea9d3c8 fd010017 ceacf340
c0225ce0                                                     Jan 10
07:16:11 oder kernel:        485e19ac f85e19ac 00000001 00000003 c79dbe94
00000000 c016027a c79dbed8
Jan 10 07:16:11 oder kernel:        485e19ac f85e19ac 00000000 00000000
c70dcdc0 f85e19ac 485e19ac 00000000
Jan 10 07:16:11 oder kernel: Call Trace: [ip_route_output+206/216]
[udp_connect+234/368] [inet_dgram_connect+61/72] [sys_connect+91/128]
[d_alloc+24/336] [d_alloc_root+49/60] [get_fd+56/152]
Jan 10 07:16:11 oder kernel:        [sys_socket+51/120]
[sys_socketcall+140/480] [system_call+52/56]
Jan 10 07:16:12 oder kernel: Code: ff ff ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
Jan 10 07:16:13 oder kernel: invalid operand: 0000
Jan 10 07:16:13 oder kernel: CPU:    0
Jan 10 07:16:13 oder kernel: EIP:    0010:[ip_route_output_slow+944/1336]
Jan 10 07:16:13 oder kernel: EFLAGS: 00010297
Jan 10 07:16:13 oder kernel: eax: 00000001   ebx: c6bd1e64   ecx:
485e19ac   edx: 485e19ac
Jan 10 07:16:13 oder kernel: esi: cfff6484   edi: 00000000   ebp:
485e19ac   esp: c6bd1e44
Jan 10 07:16:13 oder kernel: ds: 0018   es: 0018   ss: 0018
Jan 10 07:16:13 oder kernel: Process sendmail (pid: 1543, process nr: 84,
stackpage=c6bd1000)
Jan 10 07:16:13 oder kernel: Stack: 485e19ac 00000000 c6bd1e54 c6bd1e54
cea9d3c8 fd010017 ceacf340 c0225ce0
Jan 10 07:16:13 oder kernel:        485e19ac f85e19ac 00000001 00000003
c7526dd0 00000000 c016027a c6bd1ed8
Jan 10 07:16:13 oder kernel:        485e19ac f85e19ac 00000000 00000000
c701fd00 f85e19ac 485e19ac 00000000
Jan 10 07:16:13 oder kernel: Call Trace: [ip_route_output+206/216]
[udp_connect+234/368] [inet_dgram_connect+61/72] [sys_connect+91/128]
[d_alloc+24/336] [d_alloc_root+49/60] [get_fd+56/152]
Jan 10 07:16:13 oder kernel:        [sys_socket+51/120]
[sys_socketcall+140/480] [error_code+45/56] [system_call+52/56]
Jan 10 07:16:13 oder kernel: Code: ff ff ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
Jan 10 07:16:13 oder sendmail: sendmail startup failed
Jan 10 07:16:35 oder PAM_unix[884]: (system-auth) session closed for user
ksp
Jan 10 07:16:35 oder gdm[884]: gdm_auth_user_remove: /home/ksp is not owned
by uid 0.
Jan 10 07:16:35 oder gdm[884]: gdm_auth_user_remove: Ignoring suspiciously
looking cookie file /home/ksp/.Xauthority
--- /var/log/messages --- END

Please tell me what additional information you need to debug.
I'm familiar with SVR4 Kernel debug (vmcore.x crash.x),
but I miss these tools under LINUX.

With kind regards


Dieter Kasper
Comment 1 Dieter Kasper 2001-01-15 11:54:47 EST
Created attachment 7616 [details]
problem description with more details
Comment 2 Arjan van de Ven 2001-01-24 12:34:57 EST
It seems that your laptop doesn't "revive" the network-card or the
pcmcia/cardbus interface after a suspend. This is usually a BIOS bug,
but you might be able to work around it by doing a software "eject" and "insert"
of the card.
Comment 3 Dieter Kasper 2001-01-24 13:08:11 EST
I do NOT think it is a BIOS Bug.

Because I used RedHat 5.2 with a 2.0.36 kernel on this notebook
(Siemens Mobile 800) before and I never had this PANIC with rh5.2

I use (and used with rh5.2) the following commands (within a script: undock) to
suspend/resume my notebook:
/sbin/cardctl eject 0
/sbin/cardctl eject 1
sync; sync
apm --suspend

One different behavior between rh5.2 and rh7:
In rh5.2 there was no automatic recognition of PCMCIA cards after 
the resume. So I used a script (dock):
/sbin/cardctl eject 0
/sbin/cardctl eject 1
/sbin/cardctl insert 0 ; sleep 2
/sbin/cardctl insert 1 ; sleep 2
/etc/sysconfig/network-scripts/ifup eth0
/etc/sysconfig/network-scripts/ifup eth1

Comment 4 Doug Ledford 2001-01-31 00:48:39 EST
The description you just gave confirmed Arjan's suggestion that this may be a
BIOS bug.  Basically, Arjan said "It's a BIOS bug, work around it by doing a
cardctl eject; cardctl insert" and you said "It's NOT a BIOS bug because 5.2
worked with it, but with 5.2 I had to do a cardctl eject; cardctl insert".  In
other words, in 5.2 you *were* working around the bug without knowing it because
in 5.2 we didn't automatically detect network devices and load them.  Red Hat 7
attempts to automatically do this now, and so the bug shows up.  I would suggest
reviving the old dock and undock scripts and linking them into the apm suspend
and resume activities (there are man pages on what get's run when, but the basic
requirement is to go into /etc/sysconfig/apm-scripts and make the needed changes
based upon the directions you find in the top of the apmscript script and you
may want to just go into the file /etc/sysconfig/apmd and set the PCMCIARESTART
option to yes).  If these don't solve the problem, then please reopen this bug
report.  For now, assuming that one of these will solve the problem, I'm closing
this out with a resolution of Not A Bug.

Note You need to log in before you can comment on or make changes to this bug.